I am getting errors in the WDMYSQL since version 10.23

The error message is Error Access Violation of Address 0045CB9D in module wdmysql.exe Read of Address FFFFFFFF

Any ideas?


I’ve the same problem… have you resolve it anyway?

thanks, bye

Mine runs fine but I have seen an error like this. Sometimes it can be daft like a password error, also I have seen it go away after a restert of the MySQL service.


my problems keep again also after restarting mysql 4.1 service…

i see "23.15.35 - STATUS Connecting [Connect] 0

  • ERROR Client does not support authentication protocol requested by server; consider upgrading MySQL client" on the top
    and ERROR: Access violation at address 0045CB9D in module ‘wdmysql.exe’. Read of address 0000001C at time/date 23.15.35 27/04/2005
    in the “error log”


MySQL 4.1 has a new authentication protocol that Brian’s MySQL component doesn’t support. I think he’s looked for a newer client that supports the new protocol but didn’t find one last time he looked. You can solve the problem by logging in to MySQL using an account that has an old style password. Read all the gory details here… http://dev.mysql.com/doc/mysql/en/old-client.html

I just set the ‘use old passwords’ option from my MySQL Administrator without realising all this stuff. That was how I got it working the first time. However I never read this page which as you say explains it in great detail!!! You learn something eveyday :oops:


I have already set ‘use old passwords’ in the mysql administration, but the problem keeped; I have replace libmysql.dll with the one installed in the mysql \bin directory and now I have on top:

  • ERROR DLL compability issue, problems may result. Client DLL Info: 4.1.11
    23.47.05 - STATUS Connecting [Connect] 0

and on bottom:
ERROR: Access violation at address 00403DAF in module ‘wdmysql.exe’. Read of address 0000001C at time/date 23.47.05 27/04/2005

obviously no data in the db.


Even though I have ‘use old passwords’ set I have still seen the original problem and what has fixed it was to go in and reset the passwords and reboot the PC. I am running 4.1.7 of MySQL.


fine! finally i see weather on my db, thanks a lot!


ERROR: Access violation at address 0045CB9D in module ‘wdmysql.exe’. Read of address 0000001C at time/date 18:04:58 18-09-2005

Is this still the 4.1 password issue, and will it be solved.

I cannot use any tricks, as I have my SQL at my WEB-host, and I do not expect that he will allow me to fiddle around in his setups

Has this ever worked from WD to your hosts MySQL? If yes then I doubt it is the password problem, if no then it could be IF your hosting service is using MySQL 4.1 or above.
In the last case you would need to talk to your hosting service to see what they have set for passwords.


Brian may know more, but when we found this bug there was no easy fix. The component he was using for MySQL access hadn’t been updated to include v4.1 so the only way was to stay compatible with the earlier passwords. I suspect this is a burning bridge problem though…with MySQL v5 in beta it’s only a matter of time before people start switching over to it and I’m not sure if that has the old password compatibility built in.