WD not updating even though console is

Hi Guys,

I have an issue where WD says it is receiving date (though is showing bad data quality) from by console (Peet Bros Ultimeter 800), but nothing is updating. Temperature, wind, rain…are all stuck on a single value. I was out of town for a few days and I think the power went out causing my system to reboot. I think that may have something to do with it.

I have already reset my console and it is in Data Logger Mode, checked all connections, reinstalled WD with the latest version (On windows 10 64 bit) and restored settings from a previous month back-up. I went through everything I can think of. Does anyone have other ideas? There has to be something I am missing.

Thanks in advance!

make sure the barometer is working on the console (hold down the barometer button)

Thanks for the reply. My station does not come equipped with a barometer. Though oddly enough does have a button and it shows —.-

it could be a problem with the baud rate then maybe
also post a screen shot of how you have the weather station type setup in WD

Attached is the setup.I believe this is how it was set up and working before, but maybe I am missing something. Let me know if this is not what you need to see.

Issue solved! I had to turn off “use complete record mode”. Thanks for looking into this!

Hello there, I have a problem with Weather Display, I hope you can help me here.

Weather Display stopped receiving data from the station. When I disconnect station from computer and start WD, shows frozen readings (temp 23.6 °C and everything else). When I connect the station and start WD, same thing happens. Worked normally until last night. Any ideas ?

Greets Marko. :slight_smile:

what weather station type?


was helping a friend who has a Ultimeter 2100 and had a hell of a time getting the Ultimeter 2100 to communicate correctly with WD Until we used the attached settings below.