WD not getting updated data from WS-2308 console

I’ve been running WD with my WS-2308 console for a few weeks now with no problems. Beginning last night, WD is not receiving/updating certain data elements, including temperature, dewpoint, wind speed and direction, humidity and rain totals. However, the barometric pressure does seem to be updating.

A restart of WD gets the data flowing again but only for a short time, then it stops again.

Anybody seen this before?

Any errors in the programerrorlog.txt file in your wd install location?

have you replaced the cheap wiring cables with better quality twisted pair and sheilded cable?
i suspect that at times you might be getting data spikes and that is the root cause of the problem
or, also, what is the actual barometer reading?

There are no errors in the programerrorlog.txt file. I have not replaced the wiring, however the data is coming in to the console with no problems. The console shows accurate, updated information on a regular basis. However the data does not update in WD. As soon as I restart WD, it shows the correct data for a while, then the data stops updating again.

The barometer reading is accurate–currently 29.93 inHg.

Have you tried running Heavy Weather for a period of time and see if that hangs up as well? If so the problem would be with the communications from the console to your machine…


does the data received light keep on flashing?

I haven’t tried running Heavy Weather yet. The WD data light does continue to flash green and the barometric pressure reading continues to update. The data quality light also stays green.

I’m having a long streak of updating data right now since the last restart. If it hangs again, I’ll try Heavy Weather and see what happens.

Some storms are rapidly moving into our area (Lake Villa, IL) so I’m hoping the rain gauge updates!

Thanks for all the advice!

i do have a debug mode I can enable for you and upload that update