WD Flatlines

Does anyone have a checklist of possible causes for WD to “flatline”? It’s reporting data from an Oregon 928 which is attached to my PC via one of these Virtual Com ports, over the network. Periodically - maybe two or three times a week, often overnight, but also during the day when the computer is in use for other things, the graphs just flatline and the “Data Received” figure fails to increment, for no apparent reason. I have to close WD, close and re-open the Virtual Com port, and re-start WD, to get it running again. If I haven’t noticed it for a few hours it obviously leaves an ugly “step” in my graphs when it restarts. The weather station itself seems fine during these flatline periods, and its own display is registering data from the various sensors and instruments, so somewhere in the chain from weather station to Com box via Ethernet network to computer to WD, there is a blockage occuring. I have checked the Windows event logs and nothing is reported for the times at which the data stops. You can tell more or less the exact minute the data stopped flowing by looking at the WD log file and seeing where the rows of identical numbers start. Anyone else experienced this? Any ideas where to look?
Best regards

you could try the new, reset the com port every hour, in the com port setup, in the latest version
that migth do the trick
(it sounds like the com port is being lost)
(that station type just sends the data without having to request it)

I agree With Brian.
sounds like a com port problem
I have a WMR928N myself and no problems with any flatlines or com port problems
Only when starting wd it takes a couple of minutes to set the first extra sensor which is used as a soil sensor. the other sensors are show straight away


I’ve upgraded to 10.20p and tried the “reset com port every hour” setting overnight, and this seems to have made matters worse. A flatline started at about 10.30pm, looks like the com port reset worked at 02.45am as there is a graph step, at 03.45 another flatline starts, and at 06.45am there is another step in the graph so the port must have been “found” again at that time. Closing WD and re-opening it is not enough to get it going again, I have to close WD, then close the com port, then re-open the com port then re-start WD. Could it be something to do with a conflict with another device perhaps? I have various other things plugged into USB ports for example.

I suspect the answer will be no, but is it possible to run a test with the console directly connected to the PC? That might help to isolate the problem to the virtual COM port software and the RS232->Ethernet adapter.

I could connect it up to a laptop but all my data would then end up on the laptop for the duration of the test, however I have found a setting to “enable log” on the Virtual Com software so I have enabled that to see if it gives any clues.