Virtual VP-lost connection.

Hi,
Still running the trial, getting on really well until now :frowning:

After pressing the forecast button on the consol I lost the connection

activity log as follows:

01:17:26:578 Warning - VpConsole: No response after several retries for Wake Up Console
01:17:28:656 Warning - VpConsole: No response after several retries for Get Live Sensor Data
01:17:29:843 Warning - VpConsole: No response after several retries for Wake Up Console
01:17:31:046 Warning - VpConsole: No response after several retries for Wake Up Console
01:17:33:203 Warning - VpConsole: No response after several retries for Get Live Sensor Data
01:17:34:390 Warning - VpConsole: No response after several retries for Wake Up Console
01:17:34:390 Error - VpConsole: Several consecutive failures of console to respond. Will try to reconnect.
01:17:36:000 Warning - VpConsole: No response after several retries for Wake Up Console
01:17:38:078 Warning - VpConsole: No response after several retries for Get Live Sensor Data
01:17:41:062 Warning - VpConsole: No response after several retries for Wake Up Console
01:17:44:328 Warning - VpConsole: No response after several retries for Get Archive Page
01:17:44:328 Warning - Archive page packet failed CRC check, requesting again
01:25:15:375 Warning - VpConsole: No response after several retries for Wake Up Console
01:25:17:453 Warning - VpConsole: No response after several retries for Get Live Sensor Data
01:25:18:921 Warning - VpConsole: No response after several retries for Wake Up Console
01:25:21:000 Warning - VpConsole: No response after several retries for Get Live Sensor Data
01:25:22:203 Warning - VpConsole: No response after several retries for Wake Up Console
01:25:24:281 Warning - VpConsole: No response after several retries for Get Live Sensor Data
01:25:24:281 Error - VpConsole: Several consecutive failures of console to respond. Will try to reconnect.
01:25:25:890 Warning - VpConsole: No response after several retries for Wake Up Console
01:25:27:968 Warning - VpConsole: No response after several retries for Get Live Sensor Data
01:25:30:906 Warning - VpConsole: No response after several retries for Wake Up Console
01:25:34:187 Warning - VpConsole: No response after several retries for Get Archive Page
01:25:34:187 Warning - Archive page packet failed CRC check, requesting again

any ideas ??

Rgds Stuart.

There are a number of interactions with the console that will stop serial transfers. Pressing the button that displays the forecast is one of them. This has nothing to do with VirtualVP. It’s a “feature” of the console.

I did make a change to VirtualVP not long ago to increase the amount of time it tries to get an answer from the console before going into the mode where it tries to reconnect every 30 seconds after the console stops talking. This change was made specifically to accommodate the console behavior after pressing the forecast button. Make sure you’re using the latest version.

Steve

Thanks Steve, as long as its not me, or my set up.

If this or similar does happen is there any way of using Start watch maybe to establish the connection again?

Rgds Stuart.

The current version of VirtualVP will try for around 20 seconds to send wake up commands to the console if it keeps getting no response. Then it disconnects from the console COM port and goes into a mode where it connects and tries to talk to the console about every 30 seconds. Additionally, if you have the USB data logger, and you enable the option to do this, VirtualVP will programmatically reset the Davis USB driver (the same effect as unplugging and plugging back in the USB cable) after that first disconnect. So if the connection can be salvaged, VirtualVP will do it by itself.

Steve

Thanks Steve,
may be I didn’t leave it long enough after pressing the forecast button and waithing for reconnection??
Thought I would give it a go…pressed the forecast button and lost the connection.
the 20 seconds passed and then I waited for the 30 second re connect…didn’t happen?
I left this for a further 4 minutes, the had to reconnect myself.

I have the trial version V1.1.1.2 and a serial data logger.

Just dint press the forecast button!! and hope all will run OK under any other circumstances!

Rgds Stuart.

Stuart,
Try upgrading to the latest Virtual VP V1.1.4 Beta.

It resolved that exact problem for me. I’m also using a serial data logger. 8)

Yes, v. 1.1.4 would be the one to use.

Yep sure is … that’s done the job, pressed the forecast button and VVP sorted it.

I just have to purchase now!

Thanks and Rgds Stuart.