Updated steps from a user re Davis USBExpress mode

1). I searched for ‘Weatherlink utilities’ and found this link: https://www.davisinstruments.com/support/weatherlink-utility-cp210x-usb-to-serial-converter/

2). I had to close the Weatherlink software and then I placed the USB to Serial Converter utility in the C:\WeatherLink\Support\Utilities folder.

  1. I ran the executable which was successful. The converter utility changed the USB to a virtual serial port using COM3.

4). I opened “Weather Display”, went to the ‘Control Panel’ and selected ‘Station Type & Settings’ and changed from COM1 to COM3. Data then started coming in.

This utility ships with WeatherLink 5.8.0, but will not run due to a compile error. This update, version 2.0, works properly.

Note: This download only applies to users of WeatherLink 5.8.0 and a USB WeatherLink data logger.

The current version is 6.x.x so it maybe that the included function works OK in later versions of WL.

this was a updated steps that a user wrote up
so if the current FAQ needs tweaking/updating :slight_smile:

Im having this issue on my parents new VP2. The converter you mention doesn’t work on Win7. What system did you try this on Brian?

Here’s a SS of the converter that I ran. It says its in Serial port mode, but It doesn’t tell me what Com port it is. And device manger is not showing any serial ports.

Platform: Windows 98SE, 2000, ME, XP, Vista


Generally if it works on Vista it should run on W7. Have you tried it?

I tried it. I just updated my last post with some info.

Which driver did you install? Download for Windows 7/8/8.1 (v6.7.6) has been shown to be good in past threads.

This one from Silicon Labs… Package version: 6.7.6 Release date: 2018-06-05

But when I follow Brian’s instructions and execute the USB to Serial converter I get what I posted above. “The Screenshot”

The silicon labs is saying com 7, but that’s not correct. When I run the converter that Brian posted, it doesn’t state the com port.

As a side note… When I set WD at com 7, the data receive blinks green but doesn’t count it. The data quality stays red.

You should see the comport number
Allocated in windows devic manager
Also check the baud rate

That’s the problem, no com port is showing. The baud rate is correct. At this point it would probably be easier to get a serial cable instead of USB.

try re installing the latest silicon labs usb driver for the Davis USB data logger

I agree with Brian, if it’s not showing in device manager there’s a driver issue :frowning: