Unable to have Com Ports in the Com Port List

I have just installed the Mac version - Weather Display For PPC MAC OSX10.5 v10.37j .
I have an iMAC with the Keyspan serial - USB converter.
The problem is when i go into de Control Panel / Com Port the serial adapter list is totally empty.
What should i do in order to select the com port - ? I know that keyspan is working since i have weather Tracker working with it.



have you click on update list?
try this universal driver:


have you click on update list? - Yes i have tried that.

In relation to the Universal driver - I’m going to try to install it and them I will report the result.



T tried and installed the driver but nothing has changed, still nothing in the com port list

there is a file with the list of tty devices found
in the root directory
what is in that?

Here is what is inside the file that is located in the wdisplay directory


Nevertheless is the dev directory in the root of the system i have the following devices:

crw-rw-rw- 1 root wheel 9, 6 Jan 8 18:18 tty.Bluetooth-Modem
crw-rw-rw- 1 root wheel 9, 4 Jan 8 18:18 tty.Bluetooth-PDA-Sync
crw-rw-rw- 1 root wheel 9, 0 Jan 8 18:18 tty.KeySerial1
crw-rw-rw- 1 root wheel 9, 2 Jan 8 18:18 tty.USA19H4b22P1.1

Help would appreciated because i really do not know what is wrong…



Just one more thing, i copied the file to the root of the system since i saw that it was in the root of my user and now, yes, i do have a list of the devices, but by selecting the device and going to the data logger i get the following information ( see attached file )


where do you have WD installed to?
it should be to /Applications/wdisplay/
that file should have been created in the root folder, yes…the fact it was not, is the problem…migth be a permissions thing

also try restarting to see if it can open that com port…you are on the right track,.

Yes, it is installed in the correct place, but in my iMAC i have several accounts : mine and my wife.
Nevertheless wdisplay is installed in : Macintosh HD - > Applications - > wdisplay.
The thing was that the file ttylist.txt has to be in the root Macintosh HD in order to be able to see com ports in the com port list, the reason I was not able to see com ports was because the file was originally located in my home directory : Macintosh HD - > Users - > Vasco.
I tired allready to reboot, but the Wdisplay is still not able to open the com port.
Please do you have more suggestions - ?

Finally I was able to make it work - Tks for the Help.

what was the final solution? (in case others have the same problem)

The final solution was simple, I had another program that was locking the com Port.
Nevertheless I had a problem with the location of the tty file since I’m using multiple users and the file in the root of the user does not work, it has to be in the root of the system.
Now I have a new problem, I’m not able to activate the Weatherunderground - I have I think all the switches that have to be on - On - but nothing is being updated to the site - I even checked the configuration in the wdisplayftp.ini and everything as far as i know looks good.
Can you please help - in finding a solution to my new problem - ? - Tks


make sure the cron files are where the settings files are now stored
(I have shifted those now a few times (to make it more standard) but need to shift the cron program to that location (i.e cronwu, etc)


Hi all,

I have had the Keydspan adapter since I installed WD Mac with my WMR-968 last June, and there are a couple things that all users should keep in mind when setting the unit up.

First, ensure that the port has not been selected by another program, especially VMWare Fusion (mostly older versions of this Windows virtual machine environment). In Fusion’s release notes in the older versions it clearly states that USB ports may not be properly released when attempting to use the same port when switching back to the Mac environment. The only way to release the port in those cases is to suspend or quit the virtual machine environment (i.e. Fusion) Since some folks here do use WD Windows in the Mac virtual machine emulators (Parallels and Fusion) this can present a problem for the unaware. I know a recent update of my Fusion software took care of this but can’t speak for Parallels. There are other programs that can do this so vigilance is key here…

Secondly, Keyspan’s release notes indicates that either of the 2 ports that appear can be selected and within WD Mac I have selected both of them with positive results. The files will be named very close to the names reported above, possibly with some variation in the name related I think to model number:


Just thought I would jump in here and give my observations on this as I have had great results with the Keyspan adapter and the software drivers that come with the product, with only one small glitch in the 7 months I have used it 24/7.


Now I understand what you are talking about when you mentioned the cron files - but they are missing - I do not have a single one in the wdisplay directory.

try the latest package install update
should be all good again now

I will try the new version for PPC - version K - the reason I have not done it, is because I have not realized there was a new version since the date shows 14 Dec.