Twitter Not working

Hi My twitter will not update at all any help? I just can not see where the problem is. :frowning:

Are you just setting up Twitter for the first time? or was it working and then it stopped?

What version of WD (this should always be provided)


If new be sure you have the correct version of .net, see

Hi guys I have read and spent hours trying to get my twitter working. It used to work but then one day it just stopped. I have installed NET 4 and I have clicked on the setup oath on the bottom of the Twitter setup but nothing seems to happen. I have looked in my WD folder and noticed I am missing 2 twitter files. Can anyone help or shed light please.

Thank you all
Jack :slight_smile:

Yes I have the New Net 4.0+ and yes it was working and just stopped. I now have not twitteroauth.txt and twitteroauth2.txt files what do I do I have been at this now for offf to long lol

Got to be someone out there that can help :frowning:

It’s a Sunday morning in the UK, still night in most of the US and only a couple of hours since you posted the question! I’d give it a little longer before you use a sad smiley.

Lol ok Just I been trying to work this out for some weeks now I have tried just about everything. Reinstalled WS the lot

What version of WD?
Have you tried reducing the length of your twitter feed to see if you may be hitting a char limit?

I now have not twitteroauth.txt and twitteroauth2.txt files what do I do

I am not sure I fully understand what you are saying here?


ver 10.37R Build 07 is my WD

In my WD program folder I have nothing that has anything to do with twitter . It is all set up correct I just don’t know what to do now.

If you do not have twitteroauth.txt and twitteroauth2.txt files in your main WD directory try resetting up Twitter for the first time…


and how do i do that? I’ve clicked on the setup oauth first time use but nothing happens

That usually indicates you have some twitter related files in your main WD directory, as far as i know.

You need to search your WD directory and remove any files that say twitter…


Done that and still nothing :frowning:

Just for sanity sake…

You have closed WD completely, making sure all aspects are closed, after removing the files, and then launch it new? Possibly even reboot your machine?

If that don’t work then I am sorry but I have run out of ideas… :?


Yep been there done that lol I’m just stumped. It was working fine one day and just stopped all of a sudden :? :?

Ok so I now got Twitter working at last :slight_smile: has anyone got any good codes to show temp wind baro rain etc :wink:

It would be useful to know what you did to get it working…just in case someone else has the same problem in future.

I re installed Weather Display but in a new folder on a flash drive. Here is what I did step by step.

1: Create a folder on a flash drive or on your PC.
2: Install Weather Display to that folder (This way you won’t mess up your settings)
3: Create another folder so you can transfer files.
4: Open the folder you installed WD in and move these 3 files to your empty folder TwitterVB.dll TwitterVB.xmlSerializers.dll and also wdtwitter application.

5: once you have moved these files to your empty folder you can delete the WD folder.
6: Open your original WD folder and move all 3 files into it. (WD must be closed)
7: Restart PC
8: Open WD control panel Twitter click setup oauth for firts time use.

That’s it and follow instructions from there. Took me ages to figure out but hope this helps anyone else :slight_smile:

make sure you have .net 4.0 extended
also delete the files
twitteroauth.txt and twitteroauth2.txt

then click on the setup button (scroll down to see that) in the twitter setup

also see the FAQ about the twitter setup