The word "Solar" is missing in curr24hourgraph.jpg

re the dew point, I suspect you might be using the language.ini file option?

Yes. Of course. Found the culprit in there. Changed the ‘d’ to a ‘D’. Then clicked ‘force update now’ for lanuage.ini and restarted WD.
Also fixed! Thanks!!!