The beta Weather display and a LED display (FIXED)

With my WD Version 10.37R build 81 my LED display works just fine. but if I try to update to the beta weather display build 260. the display stops working. Is there something else that I need to do to get it working again?
Thank you.

unfortunately that was some of the code that I was not able to find in any backups
so I would need to re add back in that code
I will need some help
eg there is probably some old posts about how it worked …example code, how its done, etc…
if you could help me that would be great

one thing:
I notice there is a cronledsign.exe
with the build 81
if you run that with the beta version…and update the customledsign.txt file (not sure if that is the correct file name), does that update the sign?

I did pull the cronledsign.exe from build 81 and tired to get it to work on this one…no luck. But this weekend I am going to install WD beta on a fresh computer (running XP) to see if that helps any.

I did find this thread not sure if that will help. I can look some more if you still want more info.

Thanks for the reply

if you have the beta version running
where build 81 is installed and working then test?

I tried it. and no luck. the sign updates just fine with build 81 but after I update it to beta it stops. I even found cronledsign.exe and started it but it did not seem to help.

Any other thoughts on how I can test it?

Thank you for your help.

the cronledsign.exe should be using a file for data (I cant remember the name of the file)
or maybe even data in the ini files
see if you can find that and then manually update and run the cronledsign.exe (with the beta version) and see if the sign updates

ok I will search for it, thank you.

ok after some searching I found out that wdisplay.ini had a setting in it for the LED sign. so I moved that ini file to the beta wd but it is till not updateing. BUT if this helps any the sign resets like it is getting something new but it just keeps showing the samething.

email me those ini settings…
there must be somewhere that the cronledsign.exe is using to get the new info to send…
e.g in the wdisplay.ini file section
[LED sign]
or in the registry, in the wdisplayftp.ini section
or even a text file…where WD is installed…or in the web files folder

It works!!! I edited the wdisplayftp.ini file and the sign updated to what I edited it to.

Do you still want my files?

what exact string are you editing in the wdisplayftp.ini file?
thats the information I am needing

try a new .zip beta version update…should work

That did it. It works!!! Thank you so much for fixing it :slight_smile:

are you using the custom option?

Yes I am

just as well I added the code to handle that too late last night then :wink:

Thank you.

looks like WD is spawning mutliple copies of cronledsign.exe instead of just needing to run that once
use the latest .zip update to fix that