[Solved]WD not processing customclientraw.txt file

WD does not seem to be processing the customclientraw.txt file properly. The uploaded file contains the tags exactly like it looks in the web files directory. It does not contain any data like the clientraw.txt contains. Any advice??

Has your customclientraw.txt file worked in the past or have you just set it up?
If you’ve just set it up could you go through the setup process you used, incase someone notices something you’ve missed. :wink:

Well, I searched forum for setup info many times & I thought I had everything correct but apparently not. I have been running WDL for years using the clientraw.txt file, no problems.

  • I put the customclientrawlocal.txt file in the webfiles directory & renamed it to customclientraw.txt
  • I set WD to process a customclientraw.txt file by checking it in the the Real Time Client FTP panel
  • I set the correct path in gauges.js to read the customclientraw.txt file

The customclientraw.txt file uploaded by Realtime FTP is identical to the local file. WD is not writing data to the uploaded file.

The remote sensor status banner reports “Text file download corrupted” - this might be a config problem - not a status report


It should be noted that I have WD setup using “other real time upload settings” to upload to a specific directory “wx/wd” but I tried not using this setting and the customclientraw.txt file was in the same condition.

I believe your problem was renaming the file. Try naming it back to customclientrawlocal.txt because that is the file name that WD is looking for to process. It will then create the customclientraw.txt file that you’re looking for with the data in it.

  • Jim

Thanks, that appears to have gotten some processing done but WD is now only publishing one line in the customclientraw.txt, that looks like this:

“date”:“11:43 AM”,

According to the instructions here: http://www.hetweerinruinen.nl/steelseries-gaugs-for-wd - this may be outdated.

"In the scripts folder edit gauges.js. Change on line 11 the path into the path where your clientraw.txt is uploaded, and change the filename in customclientraw.txt"

What does change the filename in customclientraw.txt mean? There is no file name used in that file.

The FTP Log shows that the uploader is correctly processing the customclientraw.txttmp file. But the temp file has just the one line published, not other data.

Your only processing the first line:

Put the tags on one line, w/out any breaks.

So edit customclientrawlocal.txt in notepad to be on one line, then place the edited file in the WD/webfiles folder.

WD display will create and upload. There is a thread here (can’t find just now) with screen shots.

Try the attached. It’s the one I’m using and has the US units in place.

  • Jim

customclientrawlocal.txt (2.02 KB)

THANKS!!! That fixed it. I think the problem was the file shipped with SS had word wrap on or I saved with it on. Anyway, I guess “customclientrawlocal.txt” needs to be save with word wrap off, or no returns, if anyone else has issues.

My fault - I did not realize that WD only processed the first line of the customeclientrawlocal file - I had put line breaks in to ease readability. I have now updated the zip file with a single line version.

Thanks, Jim’s file had the line breaks removed, it wasn’t word wrap. But that clears it up.

I can make WD read all lines

I don’t think it’s necessarily essential, but I think it would be nice if it isn’t too much work.

  • Jim