Run-time error 55 - file already open

HI, i keep getting this error, for the last few days, i am now trying a manual run and i am still getting it, i cannot figure out what is going on, any ideas please?

I have figured out that the error comes about every time the program exits be it automatically after a run or manually “exit” from the file menu.
There are no other screens open, nothing in task manager and it will also appear even if i open the program and ty to close it straight away
without any other activity.
I am running the latest version as i tried an upgrade yesterday and i still get the error, also you can imagine that auto running now is not possible because of it.
I have tried changing alreadyopen to 0, same error, one is at a loss now.

As a side note, i am using the beta program of wxsimmate to see if that made any difference, was worth a try, there is an issue there, nothing serious but, if there is an issue with the data download, i.e UV from Temis, sometimes that will take awhile and work and sometimes it will fail with an error and i have to say ok to 2 notices, on the beta version it takes a lot longer before the notification boxes show, perhaps the timeout is set longer?
It would be interesting to know why Temis is having this issue, been like it for quite sometime now, theres the odd time it will work ok though

I get it with wxsimlite too, somethings gone haywire, poss due to a system crash or changing to DST, i do not have a clue


It looks like it’s something Tom is trying to track down - See

Thank you, i will take a look

Hey BMX,

I’ve been fighting this same error in WxSim for 2 weeks and have finally resolved it. Here’s what I’d recommend to get you started in finding the problem.

Make sure WxSim, WxSimate, and WxSim-Lite are all closed.

Open each of the following files and make sure they contain a ‘0’ in the first position of the file and nothing else. If you see a ‘1’, change it to a ‘0’ and save the file.


Also, review ecdata.txt. This file should contain several lines of data. If it contains a series of NUL characters in row 1, this file is bad and you’ll need to restore a good version of this file. This ecdata.txt file is the one that was causing my WxSim not to shut down cleanly until I restored a good copy.

Hope this helps you.


Thanks ever so much Steve, it looks like it was 3 files, 2 had a 1 in them even though i had only just changed 1 of them a few days ago, and ecdata was empty 8O so i have a feeling that was at the bottom of it all, i have done an auto run and it all closed ok, i will know for sure later on this morning after a timed auto run and will report back then, thanks again

Thanks for the update. I’m glad to hear it’s working so far. Please let me know how the timed auto run goes.


Its gone through 2 forecasts with no issues, once again, thank you very much Steve

You’re quite welcome. I’m glad to hear it’s working as it should.


I do have another ongoing issue and that is, auto run not running, wxsimmate does its business, wxsim opens but does not run, you can tell its not ran because its still highlighted in the taskbar and does not close. I just cannot figure out why its not, i have experimented with different times and time of the hour and redoing a manual run to no avail, any thoughts please? because i pretty much always have to do the run myself.

Can you provide a provide a screenshot of the popup you get when you click on Schedule at the top of WxSimate?



Hi Steve, thanks, this is what i have.

I compared your settings to mine. The only thing I noticed that needs changing is the download ‘minutes’ for WxSimate. You have this running at 31 minutes after the hour, but you have WxSim running at 15 minutes after the hour. You need to be running WxSimate BEFORE WxSim. You might set the WxSimate download time to something like 6 minutes after the hour. And, if you’re running WxSim-Lite, run it around 10 minutes after the hour.

Based on your settings, I’m assuming you’re using a system scheduler to initialize each of these programs. I would suggest you check the times of initialization to make sure you’re initializing them before their scheduled run time. In the case of WxSim, you might have the system scheduler initialize it at 10 minutes after the hour so you know it’s up before the WxSim schedule kicks in at 15 minutes after the hour.


Thanks for catching that, i messed that up this morning when i was trying a different time setting, forgot to adjust wxsimate.
Heres an image with my scheduler, it looks right to me?

Your WxSim scheduler settings look OK. However, in your WxSimate settings, you show a 7AM run, but you don’t have a 7AM run in the system scheduler.

Have you watched your computer during one of the runs to see what is going on? Maybe tonight at the 6PM run, watch the monitor while WxSimate runs and WxSim-Lite runs to see if they close properly. Then watch how WxSim is initialized. Does it actually run but not close? Or does it just initialize the WxSim dialog box and do nothing? After it completes, take a screen shot of the WxSim folder sorted by latest updated files first. I want to see all the files that have changed during the WxSim run.



You have System Scheduler opening WXSimate at 00:09 and WXSim at 00:14 but you don’t have any midnight runs programmed into either.
So both are being opened and not being closed.

Try removing the “0” hour indicator from each in System Scheduler and have the first start at 4am to see if that helps. :wink:

Thanks guys,appreciate the help, i have watched them, and normally the 8am one and that runs fine, its normally the early hours ones ie the 4 am and 6am that stay open oh and the 12pm, i have only added extra ones to try and get them to run in case i something on the laptop is causing it to bomb out.

I have now removed the 0 from SS but i will still have an issue with the other early am’s

I have watched the PM ones, they obviously open with SS but thats all they do, its like wxsim doesnt know it should be actually doing something, theres also been times when ive clicked on one in the taskbar and its like its woken it up and it starts off, but thats rare, its like it needed interaction to carry on, no errors showing though.

Its certainly a weird one


I have just noticed a .net error showing, but it was like it was being invisible, not showing in the taskbar and it was flickering, it was mostly unseen and flickering very quickly… Which .net is needed for wxsim, if any? i will download it again and reinstall the .net


i am going to assume that this isnt normal (see image)?


Think ive figured it out, my scheduler isnt actually opening wxsimate, its putting it in task manager as seen in the image but its not actually opening as in, not in the taskbar

EDIT #4, think ive cracked it, i had set wmxsimate to open hidden, perhaps an update of win 10 didnt like it opening hidden, ive set it to normal and it runs fine and wxsima has now ran 3 times automatically, it looks like wxsimate v8 does not close fully as seen in the image though, it closes from view just not from task manager

No it’s not normal to have WXSim or WXSimate showing in the Task Manager Details when it’s closed.

Just to make sure the command has been saved in WXSimate; Open WXSimate > Scheduler > un-tick “Close after download and import” > Save settings and enable scheduler > exit WXSimate and check you have no running copies in Task Manager Details. Then open WXSimate again and tick “Close after download and import” > Save settings and enable scheduler > exit WXSimate.
It may also be handy, for a couple of days anyway, to un-tick " Suppress error messages" in the scheduler to see if anything pops up. :wink:

Also, just check you have “Computer on Daylight Savings Time (DST)” ticked in WXSim, WXSimate and WXSim-lite.

Thanks for that, I have gone back to wxsimate 7.4 I think it is and no longer have any in the task manager, it’s definitely v8 that keeps them live, that being a side issue and no relevance to the issue I was having, it was definitely the SS and wxsimate set to hidden that caused it, I think a win 10 update was the initial cause because it was all running fine a while back, I have set it to run 6 times in automatic and all ran fine, one more due at 14 minutes past then I shall leave it alone, they are all now set to minimise on open, the check box to do this in wxsim makes no difference, it does not minimise, I have to set it in the SS