Program lockup after midnight

I’ve begun getting some strange lockups recently. It runs without a problem all day, then if I attempt to look at the main screen after midnight, it sits there for about 30 seconds, then pops up the windows XP program error message asking if I want to send results to Microsoft. There have also been some strange, repetitive entries in the program error log during the day:
-100.0
100.0
19.1
9.9
0.0
-100.0
100.0
20.8
8.9
0.0
-100.0
100.0
18.9
9.3
0.0
-100.0
100.0
24.7
11.6
0.0
-100.0
100.0
24.2
7.8
0.0
-100.0
100.0
16.5
9.1
0.0
-100.0
100.0
21.9
8.0
0.0
-100.0
100.0
29.7
11.3
0.0
-100.0
100.0
20.9
5.9
0.0
-100.0
100.0
19.7
4.6
0.0
-100.0
100.0
27.7
7.3
0.0
-100.0
100.0
25.2
12.6
0.0
-100.0
100.0
26.8
12.8
0.0
-100.0
100.0
20.2
11.2
0.0
-100.0
100.0
18.3
11.1
0.0
0.0
0.0
0.0
0.0
0.0
ERROR: I/O error 32 at time/date 2:46:00 AM 5/17/2003

Is this perhaps a corrupt data or log file?

Jim

it will be the calculation of your long term average temperature and hi/low temperature for the current day
what version are you using? (try the latest)
it might be a bad data file from a year or so ago that it does not like…
i,.e try backuping and deleting month52002.inf if you have it

I don’t have a 52002.inf file. It seems to have begun perhaps a week ago, when I was having some problems with the program recording data after I played with a usb serial adapter (didn’t work - it’s gone now!!). I was running version 9.76x at the time. I went back to ver 9.74d which had no problem the first night, but has given the error since. I’ll upgrade to the latest version and if the problem persists, will backup the 52003.inf file and see what happens. Thanks for the help, Brian - I love the program! Now all I need to do is quit messing it up!!

Jim

keep me posted if the latest vers is OK
( and I am uploading a new verison now to fix
the bug with the internet update !

Working fine, now. Thanks again, Brian for your outstanding support! I have the original 52003.inf file back in service and things seem to be just fine using version 9.77d. I still think WD is absolutely THE BEST.

Jim