Program Error on 9.98h

I loaded 9.98h (download site said g)
I immediately get a program error on startup. Then they continue each minute. They look like this.

ERROR: ‘4:’ is not a valid integer value at time/date 8:56:50 PM 12/8/2003
Finished history data
ERROR: ‘4:’ is not a valid integer value at time/date 8:58:00 PM 12/8/2003
ERROR: ‘4:’ is not a valid integer value at time/date 8:59:00 PM 12/8/2003
ERROR: ‘4:’ is not a valid integer value at time/date 9:00:01 PM 12/8/2003
ERROR: ‘4:’ is not a valid integer value at time/date 9:01:01 PM 12/8/2003
ERROR: ‘4:’ is not a valid integer value at time/date 9:02:00 PM 12/8/2003

I am running on a 1.1 GHz Compaq with Windows Me with a WS2310.

I tried a few restarts but it continues.
I have now reloaded 9.98e again and all is normal.


I Just tried .99 and had the same error with ‘8:’ instead of 4

if one of you guys could email me your settings:
wdisplay.ini from c:\windows or c:\winnt
wdisplayftp.reg from the databack up folder (click on action, back up data, then back up now)

i get it too!
trying to track it down now…

found it
i had put in where if 12 hour instead of 24 hour option, the times for the sun /set, etc, would be , say 8:35pm
that caused the problem
uploading 9.99a which fixes it (goes back to the way it was)until i can get it working that way i intended (tomorrow)


I loaded 9.99c.
Yes, the minute by minute interger error is now gone.

You picked up a new problem with 99.9C.

After a program shutdown period, used 10 minutes as a test 3 times,
on restart with WS2310 data gathering on, 9.99c says that it’s gathering
10 minutes of data. The 2 meters work fine during the gathering and
the error file reports history collected and finished as normal.

BUT the data does not make it to the graphs, dailylog or 122003lg.
One minute logging then continues from the current time to the graphs
and log files with the gathered data missing.

As I said, I tried it 3 times. I then reloaded 9.98.e and once again the
gathering works fine and gets recorded.

By the way. With all the experimenting with the beta versions, I have
at times made a mess of my graph data. I have been able to fix the
log data though. If dailylog or 122003lg have correct or corrected data
in them, is there any way to get that data into the WD graph data to correct them?

I’ve been experimenting with the graph correction screens trying to find
a way to get the good data from the logs back into the WD program, but
have been failing miserably. Clicking on “Correct” after selecting the
range just repeats what was already there. I tried both “Correct” and
“Retrieve”, since I don’t know the difference. The only really change I
was able to make was when I cleared 24 hours of graphs to see if I could
then rebuild them from log data, but failed again.


oh, i didnt change much, i wonder what i upset…
resetign grpahs
if you are happy with the log file
go, action, import log files, convert wd logfiles to graphs
and then click on convert

i will add a rebuild the weekly graph at some stage too

ah, i see the problem
silly me
i removed 1 line of code, and did not think i needed it
uploading a new version now, 9.99d

Boy, are WE good. :multi:

What a Team. :smilecolros:

Me with my superb error descriptions :flasingsmile:
and you with your eagle 8O eyes for finding bad code.

I’m off to try your directions to reconstruct some graphs.

(PS. I can download your updates in 70 seconds. Eat your heart out.)

you are like a breath of fresh air

Please speak up, so I can try and help with your problem

thats now thats funny

i was typring this in another thead, and some how it ended up here!

Please speak up, so I can try and help with your problem Thanks
Actually Brian, I have no serious problems at all. I'm quite happy with how 9.98e works with my WS2310. And my experimenting with 9.99d below, is in an effort to help you out. Your directions for updating graphs from logs worked great and now all of my graphs are P-R-E-T-T-Y.

By the way, if you are the author of
a post, you can change or “edit” it if you forgot to say something. Just
click on the edit button on your post, even days later.

If you want to quote what someone else said, click “quote” button at
the top of their post and you can then include all or part of their text.
Just like I did above. (I know that this forum’s format is new to you)

Now on to 9.99d.
I tried it last night and had problems with it so I went back to 9.98e.
I was too delerious at 0130 to report what was wrong, so I went to bed.
I tried again tonight. In fact, I re-downloaded 9.99d.
I see that you must have made a minor change to it since there is a 12/10
and 12/11 version of it that differ by 1KB in size.

Tonight, bringing up 9.99d for the first time, it froze. No WS2310 data
gathering startup screen and no receiving of data indicator.
Program Error log was:
82 9A B2 8A C6 06 C2
History Stage 1
History Stage 1 (that’s all)

I shut it down and started it again.
I got the data gathering screen, it went through all the normal
motions of collecting 6 minutes of data, but did not record that data
anywhere. (log files or graphs)

Program Error log reported some history stages and a finished history.
but there were no Raw # entries in the error log.

It then started to record current info on the minute and work normally.
It even updated my website on the 10 minute mark.

I then reloaded 9.98e which works great and it collected all the missing
data on startup.

I think you can fix this by comparing the code in this area from 9.98e
with 9.99d.


hi herb
i just tested, and it works for me
Now, I know people hate it when I say that,i have been told that, but here is a screen shot, showing the new graph data just after the straight lining, so i am not sure why its not working for you, after I did fix 1 line of code that I upset…hummm…what is your current barometer reading (mb?)


Current barometer reading is 30.017 inches or approx 1017 millibar.
I use an offset of 15 to get my gathered data close.

I just don’t know why everytime I toggle between 9.98e and 9.99d
it goes from working to not working. I’ve done this cycle 4 times.

What are your ideas on the error log not having any
“history raw # xxx” information.

something is ammiss then
i will add some more debug code so we can figure it why and what has changed
hang in there


Sent you an email at [email protected]

9.99d finally gathered and recorded some data.
I sent the 2 different error logs that were created.
One by 9.99d, the other by 9.98e.



Thumbs Up for the Latest Beta 9.99d
The 12/12/03 9.99d version, so far, has worked great for me.
And I have seen some of the new features and I like them.

Here is my theroy on raw# during data gathering and no raw# info.
I believe it CAN work without raw, but its operation was very intermittent
with the WS2310 console. It had taken me about 10 program starts
until I finally saw it collect and record data. Also, since it was failing
during the collection process, it was knocking the crap out of the program
and my PC, giving me so many error conditions my head spun.

Now with the raw# routine back in, it has not failed to work time after
time. Strange, especially since it worked fine for your test setup.
It could be minor differences between WS2310 consoles. Mine is only
2 weeks old. So if it works for yours and it works for mine, the way you
have it now, I would leave it alone.

I like the unit choices you put on the records screen. That is a real
time saver since I don’t use any of the past defaults. I’d like to see
you continue that in the future and include a kt vs mph choice for wind.

Thanks for all your help. I’ll keep my eye on 9.99d

Appreciate your efforts,

Umm, forgive me for asking, but where IS 9.99d??? I can only find 9.97h on the download site. Thanks in advance.

Nevermind, I found it, UGH! First day with my NEW EYES!.

9.99d is the latest beta
download from here:
and see the link to the beta version :slight_smile:

Herb:ok, thats very interesting
What must be happeniing then is that the logging of the raw data (thats all I changed) must be putting a small delay in that is needed (a delay between requesting more data)
strange but true!
what speed PC do you have?

oh and glad you noticed and liked the fact now have it where you can enter the temperature in oF for the enter your own all time records
I will add in mph then too soon