Problems getting WDconsole going

I have downloaded the latest version of wdconsole, and unzipped the files into /wdisplay/ and /wdisplay/deploy/
When I start the programme with ./ I now get the message
./wdconsole: error while loading shared libraries: cannot open shared object file: no such file or directory
I have confirmed that the library files are in the deploy directory. The file premissions for all the files in the deploy directory are set to -rw-rw-r–.
Any suggestion. I am running the software on a Clarkconnect server (v4.2)
Thanks Peter

Probably the path to the libraries is not correct. Maybe you can fiddle around in and play with the line export LD_LIBRARY_PATH=~/wdisplay/deploy/ . Change the tilde into the direct path to the directory. HTH, --Hans

Many thanks. I got rid of the tilde and that worked but now I get a different problem. The latest result is as follows
./wdconsole: error while loading shared libraries: cannot open shared object file: no such file or directory
I cannot find this file anywhere. Note I am using a Davis VP and the config file is set for a com port.
Any ideas?
Thanks Peter

try unzipping these files to the deploy folder

I have these files in my deploy folder, but still get the same error re finding

I will have a hunt for that file on my linux PC later today
(the inlaws have just arrived from a trip to China and they are sleeping in my office, where the Linux PC is!) is located in /usr/lib or /lib.
please do a ls /usr/lib/ilbusb* and ls /lib/libusb* then post the result.

I take that then it should be inlduded with a Linux Distro already Yves?

Yves, Brian
There was no libusb installed on my machine. I now installed the latest distribution from Clarkconnect and get the following error message on starting the programme.
./ line 20: 10317 floating point exception .consolewd
After some searching through this forum my next step was to do a rpm -q query on a couple of packages and I get
Are these likely to be the problem?
PS please bear with me as I am an absolute novice to linux! My concern is if I try and upgrade any software from other distributions if it will mess up other running apps?

that error occurs with if not using a recent libc

try though renaming to use the old in the deploy folder

Brian, as a linux newbie, can you please spell out which files need to be renamed.
Thanks Peter

The assumption made in the script is that you will unpack the wdisplay code into a directory named wdisplay directly under the home directory of whatever user you’re going to run this system as. This isn’t a very good assumption.

It would be REALLY nice if a README.txt file were present, that said ANYTHING about how to run this. I’ll be happy to help create such, if I can get the software to do something useful first (hard to document what you can’t get to run).

I’ve gotten as far as the floating point exception: line 20: 17637 Floating point exception./consolewd

that info about the install location is with the full linux version
I am assuming people have that working first

renaming the file is not hard…there is that needs to be replace …which might help with people using over libc on their system

be happy to help create such, if I can get the software to do something useful first
bit of an assumption their yourself that it might not do anything usefull

to see what it does do, see the original thread (non w widnows vesrion), or the thread announcing it, on this section of the forum
or just dont use it (no skin off my nose, as its free to use (I would rather have enthusiastic people use it than non enthusiastic people)

I have renamed to and tried starting the programme again but still get the same message:
./ line 20: 31789 floating point exception ./consolewd
I have posted a question on the Clarkconnect forums about updating gblic, but no response there yet.
Any other suggestions?
Thanks Peter

Yves might be able to help about your current libc version: glibc-2.3.4-2.39

Yes this is the problem glibc must be of rev 2.5 or later.
the version of libusb is greater than 0.1.4 thus it shoould be OK.

add ‘chmod +x’ for executable files…