Problem Starting WD on MAC -> oK now, had not loaded the library package

I have been trying to get WD working on my MAC Pro. :frowning:

I just downloaded the latest version. When I attempt to start it, I get a MAC error message that says “The application WeatherD quit unexpectedly”. I have three options to respond (ignore, report, relaunch). This occurs every time I try to start it.

Any help would be appreciated.

Thanks, Arnie

check the permissions of the wdisplay folder and the application bundle folders are correct for read/write and ownership are OK
and then also try deleting the wdisplay.ini and wdisplayftp.ini files from the folder

the permissions of the wdisplay folder seem fine. Where do I find the application bundle folders?

I can’t find any .ini files in the MacOS folder. Should they be there?

thanks for your help.

right mouse click on the WeatherD icon


read/write permissions are set for users: arnie(me)/admin/everyone
for the wdisplay folder, and the Read/write is also set for the bundled folders Contents, MacOS and Resources.

Not sure what to do next.

have you tried deleting the wdisplay.ini and wdisplayftp.ini files from the MacOS folder (see my post above)
also are you using the latest version (now build 16) as there was one version that would not start up

I’ve looked in the MacOS folder and don’t see any .ini files to delete.

I just downloaded the file today.
Weather Display For Intel MAC OSX10.4/10.5 v10.37i
(installed to Applications/wdisplay). See the WD forum for more info
Version on 7 September 2008 - 02:33:18

this is on a intel Imac?
try running a terminal window
then go
CD /…/
CD /Applications/wdisplay/

and post the result here

Sorry to be so dense. This is on an Intel Mac Pro

Here are the results from the Terminal window. I must be doing something wrong.

Last login: Mon Sep 8 07:34:04 on ttys000
Macintosh:~ arnie$ CD /…/
/usr/bin/CD: line 4: builtin: CD: not a shell builtin
Macintosh:~ arnie$ CD /Applications/wdisplay/
/usr/bin/CD: line 4: builtin: CD: not a shell builtin
Macintosh:~ arnie$ ./WeatherD
-bash: ./WeatherD: No such file or directory
Macintosh:~ arnie$

Use lower case for commands, and mixed case for the directories…type exactly as shown:

cd /Applications/wdisplay/

there is a space between cd and /Applications…

Thanks. I did a copy/paste to ensure the correct case. Here is the result:

Last login: Mon Sep 8 14:19:46 on ttys000
Macintosh:~ arnie$ cd /…/
Macintosh:/ arnie$ cd /Applications/wdisplay/
Macintosh:MacOS arnie$ ./WeatherD
dyld: Library not loaded: libutils.dylib
Referenced from: /Applications/wdisplay/
Reason: image not found
Trace/BPT trap
Macintosh:MacOS arnie$

Thanks for your help. What next?

Is the file libutils.dylib in your wdisplay folder? Try setting the wdisplay directory to read/write again. When you install the WD dmg file it tells you some things that need to be accomplished. From the readme.txt file:

For first time use: Make sure that the /Application/wdisplay/ folder has Write/Read permissions set

For WMR100/200/Irox users, you will first need to run the from a terminal window (run that via applications, utilities), then, you will need to download and install the Login IOUSBFamily driver upgrade from:
and then reboot after is been installed.
Note, for OSX 10.5 there is no Intel/Power PC separate driver, but for 10.4 OSX you will need to uses the Intel driver download link (for OSX 10.4.10)
Back up your important information first before doing the driver upgrade.

Also double click on the wdlibraryinstall package to install the needed library files

then you can double click the WeatherD icon to launch WD

To upgrade to a new version of WD, save the datafiles/logfiles/webfiles folder and the WDISPLAY.INI and wdisplayftp.ini files from ion the application bundle (right mouse click on WeatherD) . in the contents → MacOS folder

Thank you. I missed installing the wdlibraryinstall package. WD starts now.

Based on what I read in the readme.txt file, there is no additional serial/usb driver to load if one is using OSX 10.5. Is this correct?

ah, thats why it did not run…you needed to double click on the library install package :wink:
and sorry about the CD instead of cd

now, is it a serial or usb data logger?
if a serial data logger, then you will just need to have a USB to serial convertor and driver loaded
if a usb data logger then you would need a driver from davis loaded
either way the needed com port number should show up in the com port setup after clicking to refresh the list there

It’s a serial data logger. Everything seems to be working now. Haven’t tried the internet upload yet. I’ve copied over all the logfiles, datafiles and webfiles from Windows. Not sure what to do about my lightning detector as the Astrogenic software doesn’t work on MAC.

Thanks for all your help.


And there are no pci slots on the iMac either…if you bought the LD-250 then it may be possible to run it under parallels or similar…perhaps someone reading the forum who has tried it can chime in and let us know how they made out…

I originally had a PCI Stormtracker on a PC, but when I moved to MAC I bought the LD-250 and have had it running under Parallels for a year now using Astrogenic software. WD/Windows has also been running under Parallels. Parallels is not totally trouble-free and I would prefer not to use it if MAC software is available. Thus, I’m trying the MAC version of WD. :slight_smile:

Good deal. Is WD gathering good data for you now?

Seems to be running ok; except after the computer has been off for a time, and I restart WD, it does not appear to read the data logger to capture the data recorded when it was WD was not running. In Windows, the first thing WD does is read the data logger.

Any ideas on that?

make sure the switch is on under control panel , data logger setup