Problem, generating the testtags.php with no values [SOLVED]

Hello to all!

Recently I have discovered a problem in my Weather Display Installation. Everything started when I could not see the testtags.php informations that they are displayed in the Saratoga Weather dashboard page
Then I realized that my twitter account integration stoped tweeting my data and displaying only this “”.
So I started the troubleshooting, figuring out that my testtags.php was created and uploaded as normally but also with no data in the file, except the same “”. Here it is an example

I’ve searched the forum, but I didn’t find anything like this.
Something tells me that there is a problem with September weather data. I’ve tried to inspect them but I didn’t find something wrong.

Any idea?

Thanks in advance for your kind help.


do you happen to have the noaawarning custom tags in use?
you could try removing those
(there is another thread about that)

Hi and thanks a lot for you reply.

No I haven’t enable the weather warning custom tag.
Actually the only custom tag that is enabled for at least 6 years, is the custom web page (wxlocal.html).

so the wx.html file looks OK localy,when the web site is not working?

Yes the wxlocal.html and the wx.html are working just perfect and they are uploading to my website
The problem is only with the testtags.php and the twitter posting.

do you happen to have the noaa warning custom tags in the testtags.txt file?

The only tags in my testtags.txt that referring to NOAA are these (I used search):

$NOAAEvent = '%NOAAEvent%'; // NOAA Watch/Warning/Advisory
$noaawarningraw = '%noaawarningraw%'; // NOAA RAW watch/warning/advisory
$noaacityname =  '%noaacityname%';	// City name,from the noaa setup (in the av/ext setup)


Regarding my problem, I just found that climatedataout.html and climatedatayearout.html are also empty, with only the message.

Does this help you to figure out what is going on.
Furthermore, in 2 days the September ends, so if it is something with my data, the problem will be fixed?

Hi again!

I am still trying to find out what is going on, with the creation pf empty testtags.php file.
Today I found that if I press the TEST button in Custom Web Page Setup, from the Web Files/Web Page/Real Time FTP/WDL configuration, then the testtags.php creating and uploading successfully. But it’s only creating when pressing the TEST, but not from the 5 minute routine job.

Any idea?
Maybe you can inform, what is the application reading in order to generate the testtags.pho from the testtagsl.txt.

As you can understand, my web page is running out of correct weather data at this moment, so for me its critical to find the the solution in this problem.

Thanks in advance for your kind help.

Sometimes, it’s enough to use WD, Control Panel, Web Files/Web Page, Web Files Setup#1 TAB – in the Web Table/HTML section,
tick ‘Create and upload testtags.txt as testtags.php’

If that does not accomplish the upload, then follow the directions at to use the “Manual setup of testtags.php upload” method.

Hope this helps…

Best regards,

Hi and thanks for your reply.

I’ve tried everything, with the classic Web Files creator and also with the Custom Internet File Creation by passing the first. The testtags.php is created and uploaded empty with only the “” statement inside.

The same situation with the Twitter add-on, that posts the current weather data every hour. Just an empty post with the same !

I’m using your script for a more than 6 years and I am familiar with the settings and the procedure in order to create testtags.php or other custom wx.html file. Never before I had problem and really I don’t know what else I have to check.

Any help we be valuable to me.

Thanks again…

Regarding the problem I’m facing.

I just found that the wxlocal.html file with this code:

[color=red]<b> Version0308</b>

%date% - %time-hour%:%time-minute%


When it is generating the wx.html, I get a different format, like this:

[color=red]<META RAW MET DATA Dry, 22:34,03/10/16,tmp 23.8,hum 34,dew 7.0,wav 1.9,wgt 4.9,dir SSE  158 �,bar 1014.0,rdy 0.0,rmt 0.0,ryr 113.5,rhr 0.0>

But the right format of the wx.html must be like this:

<b> Version0308</b>

03/10/16 - 22:31


Does anyone know the reason?

which version of WD are you using?

10.37 S23


<META RAW MET DATA Dry, 22:34,03/10/16,tmp 23.8,hum 34,dew 7.0,wav 1.9,wgt 4.9,dir SSE 158 �,bar 1014.0,rdy 0.0,rmt 0.0,ryr 113.5,rhr 0.0>
is added to wx pages if an option is set under “Setup - Advanced/Misc settings” click on the program tab and you will see “Raw data appears in your HTML web page for others” If that is ticked untick it…

You was right!
This advance option, was ticked. I unticked it and my wx.html now is also empty! :smiley: with only the inside, like the testtags.php.
I don’t know when I checked this option, maybe it was at the first time that installed the Weather Display, I don’t really now, but never I had problems.
This situation is driving my crazy, but your help is valuable for me. Do you believe that maybe this is a bug of the last versions?

I want also to inform you about something. At some point I’ve closed the application and restarted it. Then before the application do the usual file creations/upload I pushed the TEST button in Custom Web Pages Setup, then like a miracle the testtags.php and the wx.html was created successfully. But then at the the next 5 minute scheduled job everything returned in the previous situation with the empty files!

Does this telling you something?

Hello to everyone!

My installation of Weather Display, is still has the problem with the testtaghs.php generation issue!.
Any help or idea for investigation will be valuable, because after 3 months I’am thinking of changing weather software, in order to have correct web data.

Season Greetings to all of you!

I had not realised you still had a problem
if you could .zip and email me your settings files
then I can check/test here
(see the FAQ on the WD forum for how do that or check the you tube video on how to do that (there is a link to the you tube videos on the main WD web site :slight_smile:

Hi to all and Happy New Year!

Thanks to Brian, my problem finally solved. It caused by a broken/corrupted wdisplay.ini configuration file.
Brian thank you one more time, and now I know how you did this fantastic application!

sure was a head scratcher…as the problem was not occuring here with your settings files…