OS Pagefile increases to 1.1GB then everything locks up [FIXED - AVG Problem]

I placed this here because it may be a system issue rather than a WD issue.

The fields in WD on LHS go blank, any error windows overlayed are blank with just the form of cells and the [X] visible, TM will not start…

I took it down to shop and changed out two DIMM 2 1GB cards for a single DIMM 2GB and placed in the first Orange holder instead of the yellow holder.

Still the same problem.

Pagefile size keeps growing - starts off at about 830MB with WD and then grows to 1.1GB within about 9 hours and locks up the PC.

Had a purge on the 120GB HDD, old files, tmp files etc. 48GB spare space. Gigabyte board, AMD 4300 (dual core 2300 64bit), 2GB Ram.

Only started happening in last 3 weeks or so. Was running new compiled 00, then went back to 10.37P B44 full install - same thing. Went to 10.37Q B01 full install, same thing.

OS is XP SP3 with the latest installs - it sort of seemed to happen after the largest recent install I think.


Are you saying that you see in task manager that WD is taking up all that memory? You may need to show the other memory columns in task manager, that’s under view, columns in W7, probably the same in XP.

No Niko. I am not saying that. I said the PageFile use gets to 1.1GB and then all programs crash, WD has not gained an inordinate amount of fat, in fact, I have not been watching that, just trying to keep the PC going and keep my head above water so to speak. A lot of different trials and sequence watching as I have other issues with new compiler WD I am watching for details. I think the FTP function is leaving 8MB lumps of PF contracted but not closed out and released at the end of a 90s upload package - the main one. The webcam uploads give it back. I didn’t want to blame WD initially. I need some more time to watch and record. It may have been other operations like SS or KR working at different times and only recently added.

Will wait a bit and watch some more. Rebooting Windows every 8hrs at moment.





I was wondering if you thought about increasing the size of your pagefile manually. I have my PF changed on my weather computer to 2048MB min to 4096MB max. This machine also has 2Gb RAM, running Win7, but did run on XP Pro. I have had issues like that before and increasing the PF seemed to cure that.

Just thinking out loud,


Thanks John, I figured I could look at that too so just made the change tonight - waiting for PF to grow to 1.1GB before shutting and restarting. Won’t take long… I also added another 1GB RAM - up to 3GB now. All HDD are fully Defragged - Diskeeper managing that, but just limited the access periods to exclude top of the hour…


Something’s not right when the processor doesn’t drop much below 50%.
Windows does sometimes bumble away in the background re-organising or whatever it does but that shouldn’t go on for more than an hour or two

4wd - thanks for obs, but I think that may have had wxsim running at the same time or something - yes it was abnormal, but I do have a 1-wire circuit of extra sensors running, one webcam direct usb, another across the LAN, and 8sec data intervals. Normally cpu is a bit lower than that, say 25% up to 60% and up to 90% with wxsim. The last two actions seem to have helped, it lasted 8hrs through the night and only put on 220MB, to 990MB but that is still a questionable amount of Page file that is increasing and tieing down resources. I will share what i think is a normal cpu load later - just got to work here down under… :slight_smile:


It has taken about a month to solve this one - it was real and a real pain in the behind as after 8hours, the page file grew 400MB to over 1.15GB (which in itself does not seem too large considering I have 90GB spare space on the HDD) and then everything went haywire - empty data fields on WD and task manager, missing images like the dials, programs trying to start and crashing…

The problem was the latest AVG. It hounded the runtime progs especially FTPUPD.exe and seemed to keep a volume in PF - whether there was a problem with the FTP update process at that time (hanging?) I don’t know.

AVG Antivirus was the problem!!

I now have AVIRA running and it is very clean and unobtrusive and cleaned out stuff AVG hadn’t found or handled.

It also does not hog memory. CPU is also running much lower as well…

Problem solved!! :slight_smile: :slight_smile: