Option to stop a second copy of WD starting

I have found that since I updated to Windows 7 I am accidentally starting a second copy of WD by clicking its icon in the bar at the bottom … it would be great if WD had an option to not load a second copy of WD if one is already running … Thanks

but clicking the icon in the task bar should not be starting up WD again
if that icon is the actual running icon

you must have instead somehow docked a WD short cut icon to the task bar

as that behaviour does not happen here and no other reports of that

so you need to undo what you have done

You’re right … I had clicked “Pin program to task bar” for WD … it seems if you do that with WD it will start a second copy rather than opening the already running copy.

I ticked unpin program for WD and that behaviour stopped and it now opens the running copy - that’s weird cause other programs that I pinned to the task bar don’t start a second copy when clicked … thanks

WD does check for if another instance running, and reports that there is already a copy running, unless you are using a 2wd.txt file or higher

Brian,

I don’t have a 2wd.txt file and the following recipe will start a second copy of WD without a dialog box that is “waiting” to connect to the same com port that is already used in the other running copy of WD.

On a Win7 system with no 2wd.txt file -

  • While WD is running and you can see the main graph screen, right minimise WD (note, not Hide), WD will minimise into task bar at bottom
  • Right Click the WD icon in the task bar (note, NOT the icon near the clock, you want to Right click the big icon near the Start button)
  • A menu will pop up displaying three options - click “Start Weather Display”
  • A second copy of WD will open without any warning messages that another copy is running
  • The second copy will not display anything as it’s waiting to connect to the weather station that is already connected to the first copy of WD

Thanks

the warning about WD already running used to work
maybe it does not work under vista/W7

in any case as long as you do not use the dock problem, is this really a problem?

It’s not a problem for me now I know not to click it :lol: