Ongoing problems including b270

Ok, all in one place now.
System: OSX 10.11.4, Mac mini 2012 model. Intel.
WD Build 270

Using Either Arduino on /dev/cu.xxxxx
Metar download EGSS.TXT
… MORE ON THIS further down.

Most notable problems.

WD does not ‘remember’ the com port setting between starts. To restart the wdisplay, I must re-input the comport setting each time.

Then, once the comport is ‘active’ the incoming data is not read in, in any case. The display shows only a minimum set of what appears to be default values.
There is no incoming data log, nothing is shown in any log, but I do know that the Arduino is recording data, because I can monitor it with other means.
So WD is not actually reading the data coming in on the com port.

Next problem.
Although it is set to download the metar file from EGSS.TXT, it does not.
I presume that it’s ‘cronmetar’ that does this.
Run through the WD interface, it starts, but gets only to login starge, then hangs and exits.
If I run it from the command line, ./cronmetar I can see it login and attempt to pull down the metar file, but it never does. Or, if it does, it never converts it to the TXT file, nor downloads the TXT file from the noaa txt directory. There is no trace of its actions in any log file.
However, if I ftp directly to noaa and login anonymously, cd to the correct directory, and get EGSS.TXT, down it comes ok.
But… Even with a valid EGSS.TXT file in place, WD doesn’t read it, so even using that as the data source for the display fails.

So. So far,
Com port needs setting every start.
no data read from com port, although once initialised, the display starts with invalid data.
nor any ability to pull in a meteor file, and even when I do put one in the directory by hand, WD doesn’t read it.

So the display remains … Invalid.

The WDISPLAY.INI file is only 27k in size, and contains a minimum of configuration data.

In this case WD remains properly broken.

the metar download does in fact work and is not broken
I have tested it
you need to make sure you have ticked to use FTP download option in the metar download setup

as for support for Arduino support, I have not done any more on that since the last time you reported it was not working

I am not wanting to work on that particular problem when you keep on posting such negative posts

I’m sorry if I have given that impression. I am not being negative, I thought I was just clearly saying that WD on Mac was not working for me, and what parts it is that aren’t working.

eg. Metar may be working on your test bed, but its not here, no matter what setting I try.
Similarly for the other things I mention.


have you clicked on the use ftp download

its not clear if you have tested with that

I am not being negative
but you are and its very off putting

Hello Brian,
Let’s see if I can get off on the right foot this time. As you may be aware, I’ve been using WD for years and years now. It’s the best there is and you do a great job with maintaining it. So I like to keep it going. I’m not able to use the Windows box any more for the weather station, so I’ve come back to the Mac. OSX 10.11.4. This is the El Captain version.

Please remember that I am not complaining, nor being rude, but trying to outline what I have done here.
So in the interests of being as definitive as I can, I have completely removed the “old” setup of WD. From Applications. and from Documents. I then downloaded the latest version again, V270, and installed that.

Before I did that, I ran Coolterm to monitor the Arduino port. /dev/cu.usbmodem14441 The FX13 Sender from the old WS3600 unit is not sending the external temp, but the other parts still function. I’ll renew the sender later maybe.

  1. WD is not remembering the comport/device setting between restarts. Once I re input it, the display starts, but with incorrect info?

So, this is what I log from the Aduino. Note the temp is a default, and the rain is also Zeroed. Humidity, the second set of ‘’ is also missing.

$,tempc=71.0,,rainmm=0,windgustdir=W  ,windgustspeedkph=6.9,winddir=WNW,windspeedkph=4.5,pressure=1004.62,indoortempc=21.0,#
$,tempc=71.0,,rainmm=0,windgustdir=SSW,windgustspeedkph=7.8,winddir=W  ,windspeedkph=4.5,pressure=1003.61,indoortempc=20.9,#
$,tempc=71.0,,rainmm=0,windgustdir=W  ,windgustspeedkph=15.8,winddir=W  ,windspeedkph=5.8,pressure=1004.63,indoortempc=20.7,#
$,tempc=71.0,,rainmm=0,windgustdir=W  ,windgustspeedkph=18.9,winddir=SSW,windspeedkph=7.6,pressure=1004.75,indoortempc=20.5,#
$,tempc=71.0,,rainmm=0,windgustdir=WNW,windgustspeedkph=6.4,winddir=W  ,windspeedkph=4.6,pressure=1004.46,indoortempc=20.4,#
$,tempc=71.0,,rainmm=0,windgustdir=W  ,windgustspeedkph=12.6,winddir=WNW,windspeedkph=6.3,pressure=1004.64,indoortempc=20.4,#
$,tempc=71.0,,rainmm=0,windgustdir=W  ,windgustspeedkph=5.3,winddir=W  ,windspeedkph=4.0,pressure=1004.53,indoortempc=20.3,#
$,tempc=71.0,,rainmm=0,windgustdir=W  ,windgustspeedkph=11.4,winddir=W  ,windspeedkph=4.8,pressure=1004.58,indoortempc=20.3,#
$,tempc=71.0,,rainmm=0,windgustdir=W  ,windgustspeedkph=5.7,winddir=SSW,windspeedkph=3.3,pressure=1004.17,indoortempc=20.4,#
$,tempc=71.0,,rainmm=0,windgustdir=WSW,windgustspeedkph=5.7,winddir=W  ,windspeedkph=3.7,pressure=1004.04,indoortempc=20.5,#
$,tempc=71.0,,rainmm=0,windgustdir=W  ,windgustspeedkph=5.6,winddir=SSW,windspeedkph=3.4,pressure=1004.00,indoortempc=20.5,#

You can see the other variables changing as each ‘send’ comes in though. So I know that part is ok.

Now what I see when I check the WD log is quite different.

day month year hour minute temperature   humidity     dewpoint   barometer  windspeed  gustspeed direction   rainlastmin    dailyrain  monthlyrain   yearlyrain  heatindex
27  4 2016  9 13 13.0  90 11.4 1013.0 0.0 0.0   0 0.0 0.0 0.0  0.0 13.0
27  4 2016  9 14 13.0  90 11.4 1013.0 0.0 0.0   0 0.0 0.0 0.0  0.0 13.0
27  4 2016  9 15 13.0  90 11.4 1013.0 0.0 0.0   0 0.0 0.0 0.0  0.0 13.0
27  4 2016  9 16 13.0  90 11.4 1013.0 0.0 0.0   0 0.0 0.0 0.0  0.0 13.0
27  4 2016  9 17 13.0  90 11.4 1013.0 0.0 0.0   0 0.0 0.0 0.0  0.0 13.0
27  4 2016  9 18 13.0  90 11.4 1013.0 0.0 0.0   0 0.0 0.0 0.0  0.0 13.0

  1. Post reinstall, the METAR now downloads, although under it’s own hourly instruction, pressing [Test] does not do it.
    But basically a reinstall fixed that little problem.

Anyway, I’ll leave it with you, and see if a release down the line a little fixes any of these little problems.


try the latest update

Hello Brian,
I’m happy to report that the original problem of it not remembering the com port and station type seems to be fixed.
Downloading the METAR is also fixed. So I can use either the METAR to display the local weather - I’m pretty close to the METAR source, or I can use my old weather station, transmitting to my Arduino receiver.

I’m sorry to report that there is still a couple of other problems, however.

Indoor Temp label doesn’t show up on the display.
Setting the rawultimeterdata.txt creation in Advanced, creates an empty file. It then doesn’t update with anything.
Setting creation of clientraw.txt turns on the green led - but doesn’t create the clientraw.txt file.
If the ftp upload of the clientraw.txt file is turned on, it can’t be turned off. So both green leds stay on.
Oh, and I nearly forgot. The rainfall records don’t update, or show anything but zero.

However, I realise the mac version is “in addition” to the windows version, so I know it will take a while to tweek it along.
thanks for the help ,

Setting the rawultimeterdata.txt creation in Advanced, creates an empty file. It then doesn't update with anything.
not all stations update to that file..the arduino is one of them is WD getting live data now, or?

Hello Brian,
In answer to your question. “Is WD getting live data now?” Well, I can’t actually be sure sorry. I don’t think it is, or if it is, it’s doing something to it. Let me give examples from the display at this moment.
WD… Actual
Current wind speed: 22.2kmh… 1.7
Temperature: 10.0’C … 13.8
Wind Dir : N … NE-E
Humidity : 76% … 60%
Pressure: 1020hpa … 1014.3hpa
Rain Total: 0.0 … 3816mm

and a lot of the values on the display never change from that. If I start up again tomorrow, those will generally be the same values.

All of the [Extreme Conditions] read incorrectly. Using either METAR data, or Arduino input.
Rainfall data is all 0.0, using either Metar or Arduino.

The Data Received indicator stays grey for Arduino, but goes green for METAR input. The count for Arduino is inaccurate, but goes way up for Metar. Data Quality is consistent.

So for the time being I think, data from the Arduino, if it is getting it, is being mangled. Data from the METAR, if I set to station-less, and use that, seems more consistent, although it still ignores Rain, and sets a few other options wrong.

I wil do screen shots throughout the day as I get a chance, to see what changes.
But sorry, it seems to be not quite right just yet.

Best regards

there is no rain data from a metar data feed
(even in the windows version)
it looks like you are only getting data from a metar

why do you have it set that way?
(when you are trying to test working with the arduino data …I cant understand what you are trying to achieve here, sorry)
there should also be raw data info under view, debug info

Hello Brian,
Sorry for the confusion.
I only mentioned the METAR to let you know that the download of metar files now works here.

Just to be clear, I’m not using Metar data for the WD display. I am only using the Arduino data input. Or trying to.

Please see this first screen shot.

Now this second shot, I just took. It’s a couple of hours since the previous screen shot. Nothing has changed.

The View - > Debug Info contains a list like this.

Loaded all time records
Loaded units
Comport open OK
data received length 125
# found 248

data received length 126
# found 250
data received length 126
# found 250
data received length 126
# found 250
data received length 126
# found 250

So I’m not too sure what that means actually.
There is no clientraw.txt file being generated, even though I have the settings turned on, which usually gives full details of what is coming in, but that’s not being generated so I can’t check it.

Not to worry. It will all come good eventually. I know it’s a monumental task you have there, so I’ll keep checking back from time to time. It’s a great piece of software, and I’ve used it for years.


I finally have some time to look at this again
and I think I know whats wrong
I will get an update uploaded today for you to test

Thanks so much for doing that. I really appreciate it. It’s now seemingly mostly working. In any case, the data log now shows correct data coming in from the Arduino.
It is also now showing the Indoor temp. Excellent.

It also appears that [Maximum Gust Today] and [Maximum Average] wind readings may be out of whack… It’s a still as a mill pond, but the reading is showing 22.2 kmh. Not sure where it’s getting that data from, so I’ll let it run, and see what it does. It could be coming from the historical data I was getting from the Airport Metar recently.
I just noticed, that the [Maximum Gust Today] 22.2 kmh S … (At Time) 11.02 AM can’t be right, because it’s only 8:48 AM :slight_smile: Sorry.
The other wind readings are accurate, thanks.

It’s also not raining today, and I don’t know if there is any actual historical rain data now, so all the rain readings are zero’d.

If I might mention, it’s not producing the clientraw.txt file, although I have it’s location set to …/webfiles and the file creation set up is on to create one every 5 minutes.

However, the associated clientrawxxxxx files are being created.

zeus:wdisplay robert$ find . -name client* -print
zeus:wdisplay robert$ 

Data coming in from the com port.

Loaded all time records
Loaded units
Comport open OK
data received length 125
# found 248
$,tempc=71.0,,rainmm=0,windgustdir=WNW,windgustspeedkph=0.0,winddir=S  ,windspeedkph=0.0,pressure=957.28,indoortempc=21.4,#
data received length 126
# found 250

data received length 126
# found 250

$,tempc=71.0,,rainmm=0,windgustdir=WNW,windgustspeedkph=0.0,winddir=W  ,windspeedkph=0.0,pressure=1016.62,indoortempc=21.4,#
data received length 126
# found 250

data received length 126
# found 250


So pretty much most excellent. Looking good.
Thanks for looking at the fixes. It’s nice to see it pretty much working again on the Mac, I can now look into buying a replacement FX13 Data sender for the external unit.


re the clientraw.txt file
do you have that turned on , in the real time ftp setup, in the webfiles/web page setup?

re the rain data: WD adds to its own rain totals when it picks up an increase in the rain total from the station
you can set starting rain totals in WD
re wind: likely left over from when you last had metar data in use

Got it, thanks Brian. Brilliant. I missed that tiny little box to tick, [I am running my own web server and no ftp needed]
I turned it all on - and presto. The clientraw.txt file appears. It’s magic.

Looking good. Thanks for your help and patience. Very much appreciated.

Great piece of software.