No Solar since switchover.

Softvark,

I just switched over from 3.12 to 4.01. I noticed a couple of things.

I changed to one of the new wdlconfig.xmls.

  1. Everytime I go over to the page the datastream comes up as undefined, in the header, then loads the name correctly. No changes were made to the
    index.html other then the pointer to the 4_01.swf.
  2. With no changes to anything, the solar sensor is not posting data.

Just fyi…Scott

See http://discourse.weather-watch.com/t/11560 re the undefined bug.

Please post your URL so I can have a look at your solar problem.

Julian

Softvark,

I dumped the clientraw.txt, clientrawextra.txt and clientrawdaily.txt and that seemed to solve the problem with the undefined tag. However, I still cannot get the solar to read. Solar today was 1168 but solar never got off 0.

http://home.earthlink.net/~swest47/

Thanks,
Scott

Something strange going on with your 24hr solar graph data in wdl too

check what the solar % is looking like in wd…
and which version of wd?

Hmm, it does appear to be coming in from WD with those values. One for Brian I think.

Julian

knowing which vers of wd woudl help

Windy, Softvark,

WD version is 10.26z. I’m running stationless reading the data file from my Davis Vantage Pro+. Everything was fine until installing 4.01.

Softvark, is there a place that I can get a fresh version of 3.12? I want to back out of 4.01.

Looks like it’s not reading the Metar correctly either.

The solar graph may be hosed because I dumped all the .txt files hoping to get the undefined and solar gauge straightened out. It appears to be recording correctly now.

Thanks,
Scott

There’s no difference in the way 3.12 displays the current conditions compared to 4.01. The undefined in the station is a bug in 4.01 which is caused when WDL tries to read the file when it’s being updated by WD. This has been fixed in the next version which will be out either later today or tomorrow. Looking at your clientraw file WD is sending a value of 0 for the solar reading.

Julian

Julian,

The Metar seems to be working fine.

Is the graph data seperate from the display data? The graph is picking up the solar data.

Thanks,
Scott

Yes the solar graph data is in the clientrawextra.txt file whereas the current value is in the clientraw.txt file - which is still feeding the value 0…

Julian