No rain from Weathersnoop?


Today we have rain/snow.

My station and weathersnoop is recording rain, but nothing shows up in WD?

From WS:
Day Rain 0.94 24.00

I’m sure it has worked before, after I changed to Weathersnoop?

Is there some settings I can check?

Thank you

check the xml output file
/Library/Application Support/wdisplay/

there is another thread about this

the problem is that weathersnoop is not correctly storing rain where WD is looking for it (total rain)

I try with last build of 30 november but still without get Rain, when you think fix it? :wink:

Thank you! :wink:

From data.txt:


I suppose this is okay?

yes, that is OK
so that should be working
Cybermode had NULL data for total rain (not a WD problem)

I will add some debug code to see what WD is doing with the rain data

Thank you :slight_smile:

Build 67 - http connection - data.txt:

<?xml version="1.0" encoding="ISO-8859-1"?> 962.00 Unknown Rainy 11.8 92 10.5 11.8 20.7 35 20.7 20.7 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 -9999 0.0 0.0 45.0 11.8 3.81 4.32 -9999 -9999 4.32 1.00 -9999

it was my mistake
I was not converting the total rain value from inches to mm of rain
use build 68 .zip update, ready now
(there is rain debug info under view, WS2010/WS2500 data setup)

Okay - I’m looking forward to try it out :slight_smile:

Thank you

Good news - WD is getting rain data

Bad news - data are wrong

Todays rain is 1,4 mm on my station, and weathersnoop says 2 mm. I believe Weathersnoop is using wrong tip size?

WD is reporting 7,4 mm, with 0.29 in tipsize (0.2mm)

Some math must be wrong Brian?

I will try 1 in tip size, and see what WD is reporting…

Now Weathersnoop has recognize 1 mm, and WD says 25,4 mm of rain - with tip size 1.0.

Wrong inch/mm conversion?

WD assumes the rain is inches in the xml
if its mm, then I need to change the code

I thought Weathersnoop was reporting both inch and mm?

i have changed the code to reading it as mm
which looks like that is what its being recorded as in the xml output
in a new .zip update
download again in about 10 minutes from now

its nearly midnight here, time for me to hit the sack

Thank you for the good job Windy!

I looked in the data.txt, and it’s mm…

It works great now, and Boisy has corrected the tip size in Weathersnoop - 1mm to 7.03mm

Now everything works great - except the ftp upload…

if you could use a scheduler program to run the cronftp then that would be a work around
(set WD to FTP but untick to use WD’s FTP program)

I’m allready using an external ftp uploader -

It’s working great, but the ftp function worked before I changed to Weathersnoop…

could you re test that theory?
WD uses a shell to run curl to get the data from weathernsoop…

All I know is, that it worked before I’d go Weathersnoop. I’ve tried using the old wdisplay.ini, so the settings are the same, but spinning wheel is comming after 1 upload. Killall cronftpreal helps, but the spinning wheel comes shotly again…

I’ve tried to test the theory, but I could not get any data from my station without Weathersnoop. I did also make a clean install of my system, and did go straight Irox in WD, but no data…