New vers 9.47

http://www.tokaanuskihire.co.nz/wdhelp/wdisplay32.exe

temporary location…

More bad news,I’m afraid Brian: there’s some kind of keygenerator or patch circulating for weatherdisplay these days :twisted: Maybe the hacker-attack is part of this as well. In any case : they seem to think you don’t need the money and are as rich as good ole’Bill Gates. Perhaps it would be prudent to write a new registration-routine or something ??

Hi
i have known about a patch to get past the 30 day trial (you need to run it before it expires)…that crack was done a year ago…

but a code generator is more of a threat…i have been told of its existance…

If i change the way the code generation is done (its tied to the hardware and OS), then everyone will need to be issued with a new code…
1700 or so will be alot of emails…

The price of the program is a 3rd of the competition…and yet people still want to get it for free…
To those people:
developers like to get rewarded for their hard work:it means you get a better product over time.
But i do like it when people make good use of the program too.
One of my problems is the income from sales has pushed up my taxable income (i.e on top of my normal day job (a dairy farmer)), and so I am paying more tax…oh well…thats life.
I do re invest in the program by purchasing components. :slight_smile:

I sure hope its not some competition software behind the traffic attack on the server (the allowable traffic limit was suddenly reached in a very short time)…as thats very nice and uncompetitive…competition is a good thing maybe someone I have ticked off!.
Anyway, what a pain!

There isn’t a piece of code written that has left a developer’s hard drive that does not have a crack/serial/keygen. Some developer’s I know see the existence of a crack as proof that they’ve written “good stuff”. :smiley:

That said, people will pay for software that they will use over time IF it suits their needs and it works in a stable (as much as possible) manner. I think WD is amazing in its functional depth and breadth.

Tom

yup, when i discovered there was a crack, I was quite chuffed someone went to all that trouble :slight_smile:

Brian:
I still have problems with 947, Seems it appears that it is updating but the times and values are still the same on the web page. Is there something I need to watch for. The log and data file location are fine, but it isn’t uploading.

:wink:

check the files locally
and the ftplogfull.txt file to see what is happening

9.47b is the latest
you can now set the names for the weather conditions:
see under summary image setup

i.e you could have:
its raining cats and dogs

some more new icons (thanks go to gary, phillip and woody)
the later made the animated day and night thunderstorms (see under input daily weather)

Brian,

I am still getting problems with the real-time graph and the summary icon not ever changing.
The real-time graph on the webpage is either not showing properly(like only a bit of the graph is full and the rest blank or is a date of 3 days ago). I have it checked to cleanup every 3 days.
The summary image is checked to be set by the metar but never changes from partly sunny.
Just letting you know. Everything else is functioning and…
WE GOT SNOW!!!

check out the cam!

the real time graph:
i have a way to fix…i will do it soon
otherwise export me your wdisplayftp.ini file from the regsiotry, and wdisplay.ini from c:\winnt or c:\windows

Brian,
If your run across an unregistered WD webpage after the 30 days, tell the rest of us. We’ll get the "boys’ to take care of them, as wide spread as we all are. Sort of the way ham radio operators take care of stolen equipment(people) when we catch them, arrange to have coffee. :wink:
Jim :twisted:

Brian,
Earlier today the FTP was only updating about half the time. Now it has died all together. The WD program is still running but if I try to make a web update, either manual or at scheduled times, the cursor starts a little hour glass spinning(wait) deal and then after a few minutes, just goes back to normal. I never see the FTP program come up nor the WD main screen get “captured”. I restarted both WD and the PC, no luck. I downloaded and installed WD again, no luck.

HELP!!!

It’s not the internet connection, i checked that by pinging the PC locally and from a remote location.

Yep, my problem too. The ftp program icon never shows up in the system tray or minimized in the task bar. But I bet if you check the Windows Task Manager you’ll see the ftpupd.exe tasks piling up in the task list.

I’ve been at this thing the past several hours trying to get the ftp program to work. And while I was trying all kinds of different settings I would keep up with all those ftpupd.exe processes by selecting them one by one in the Windows Task Manager’s processes tab and clicking the ‘End Process’ button.

But I finally got things running…

I downloaded and unzipped the old ftp program into the wdisplay directory and things started working! The ftp program icon shows up minimized on the task bar and everything is uploading!

My connections setup has ticked ‘I have a permanent internet connection’, ‘Use Weather Display’s own FTP’, ‘Hit cancel on Reestablish connection’, ‘Show in task bar (minimized)’, ‘Produce a Log file’ and ‘Always disconnect when finished’

It’s been running fine for 30 minutes or so and I’m hoping it runs overnight…

reel house, it wil be the snow today bug me thinks, which is ok in 9.47d or later…
ted:
try not having ticked hit cancel on re-estblish connection

also, try ver s9.47e, it has a new ftp verison…
otherwise its strange how this has been happening to you…
but also try maybe not using the aprs with thew new ftp version as a test

i will try the new version as soon as my feet thaw! And I can go out to the shop.

Brian,

WD is still sending data to Anything Weather in a strange way. The first of every hour, it it decoded by AW every minute until minute 10, then once every 10 minutes for the next hour. This happens every hour. My data looks like this, timeline.

12:00
12:01
12:02
12:03
12:04
12:05
12:06
12:07
12:08
12:09
12:10
12:20
12:30
12:40
12:50
01:00

Just letting you know…

ted: try not having ticked hit cancel on re-estblish connection

also, try ver s9.47e, it has a new ftp verison…
otherwise its strange how this has been happening to you…
but also try maybe not using the aprs with thew new ftp version as a test

I unticked the cancel on re-establish and things kept running ok with the old ftp program.

I then downloaded and installed vers 9.47e but the new FTP’s behavior was the same, that is, it doesn’t show up in the system tray nor on the task bar minimized. The ftpupd.exe does appear in the Windows Task Manager process list but never uploads anything. It’s like it never gets the “things to do” from WD and just sits.

I disabled both APRS and Weather Underground as a test but the ftp behavior was the same.

I copied the old ftp program into the WD directory and uploads started working again. So I’m running the latest v9.47e with everything enabled including custom web pages but with the old ftp program.

I don’t know if this will help or not… I noticed that recent WD versions seem to process Ultimeter data much faster i.e. the counter is counting almost twice as fast. I don’t know what I’m talking about but here goes… Is it possible the FTP process thread starts up/runs too quickly and looks for the “things to do” before WD has a chance to create the “To Do” list (since it’s busy handling serial port interrupts)? I guess that still doesn’t explain why ftpupd doesn’t “show” either minimized or in the system tray. What’s different with the old ftp? Is it slower? Is it a program as opposed to a thread? OK enough of my crazy theories. I’ll shut up now.