New Setup / Rainfall Block Not Showing Past Data **Solved**

New dashboard set up, and all seems to be working. However, rainfall block does not show past data, although it does show correct data when popup graph is viewed. Not sure how to fix this.

Also, at bottom of page, the UK flag appears next to my location, not the U,S, flag. Anyway to correct this?

Thanks. --Bill

Thanks for testing the PWS_Dashboard.
There is some interesting information in the first topic of the PWS Dashboard part of this forum

Your graphs gets the “old” data from WU in another way as the real-time data.
And there is no “past-data” in the wu-realtime-api.

That past data is calculated and stored in a history file by your 5 minute cron.
So all high-lows for past data will be valid if you run the 5 minute cron.
Check this topic No High/Lows, where is history and graphs data used for, and ? cron ?

Also you can insert your current high-low values into the history file by running …/PWS_hist_update.php?pw=your_easyweather_password

You are using weather34 also. That template uses a large private-upload from Meteobridge which includes high-low values.

You selected as the default language in easyweather setup “en-uk” as your main language.

Check the _my_settings/languages.txt file
Set that line 4 to comment and uncomment line 9.
Re-run easyweathersetup and select “en-us”

Or even less cumbersome, change line 4 to
en-uk |us.svg |en-gb |lang_en.txt |English (United Kingdom)| |en-GB|


Thank you!
Flag issue fixed, working on the other.

How is this actually done? That is, what are the steps I need to take to “run” /PWS_hist_update.php?pw=your_easyweather_password so I can insert the current high low values in the history file?

With the dashboard showing in your browser edit the url to read


and press Enter.

The history should show your historical data stored at Weather Underground. If necessary you can populate that by running PWS_hist_recreate.php?pw=xxxxx first. It is usually accessed as a popup from the current conditions block:


1 Like

@bitsostring - thanks for your help!

1 Like

No problem :slightly_smiling_face:

Are you running the cron job every 5 minutes?

The cron is working but the maxiumum update rate available on my host is 15 minutes. The graph totals are now correct, but I am still working to get the PWS_hist_update.php?pw=xxxxx to work so I can fix the incorrect current month/year rain totals in the rain information block.

UPDATE: I was able to access the history file and make a couple of corrections. The dashboard seems pretty much all up and running now. Thank you for all the help.

The readme at shows another solution

In your browser
= > Go to your Meteobridge
= = > Tab Services
= = = > Tab Events

Now make a new http event,

F ill in the url to your cron-job

You can have as “many” http events as you need. The Meteobridge and most other weather-programs can fire cron commands as good or better as most provider cron-servers can.


Thanks once again, Wim. I switched the cron to Meteobridge, as you suggested. I’m very pleased to have PWSdashboard up and running. It’s a great addition to my weather hobby.

1 Like

One other issue has arisen in my setup. A NOAA/NWS alert has appeared in the upper left small block but when clicked results in this notice: “Forbidden You don’t have permission to access this resource.Server unable to read htaccess file, denying access to be safe.”
Any suggestions on how to fix this? Thanks. —Bill

Next time, could you please post un-related questions in a separate topic?

This is a new and very different problem not related to “New setup - rainfall a.s.o.”
Users of those NOAA/NWS scripts could have an answer but will not read your question.


This is the link used in the iframe:
It should work in the browser also, but as you can see, it only displays the error message.

Please check the permissions of the nws-alerts/ folder, sub-folders and files using your ftp program.

= = = = = = =

After first install the very old :slightly_smiling_face: data of the test-area will be shown as in this example


Will do. I moved the post to NOAA/NWS Alert access problem in my recent install **Solved** - #3 by BKS97