New guy, man am I lost! (TE831W-2)

I’m running Debian Lenny (32bit desktop and a 64bit server where I’d like to move the weather station once I have it figured out).

I picked up a Honeywell TE831W-2 from Costco. Seems like a great unit for the price. Everything is wireless and comes with:

Main unit (TE831WD)
Rain Gauge (TS906)
Anemometer (TS805)
Two Temperature/humidity sensors (TS33C)
(Plus standard cables, mounting, etc)

From what I’ve seen on-line it’s not a bad setup for only $99.

I’m trying to get it running with WD (QT version) and having no luck and I’m totally lost! I’ve plugged it in (USB) and when it’s plugged in I get a /dev/usb/hiddev1 created. Usbview shows:

Speed: 1.5Mb/s (low)
USB Version:  1.10
Device Class: 00(>ifc )
Device Subclass: 00
Device Protocol: 00
Maximum Default Endpoint Size: 8
Number of Configurations: 1
Vendor Id: 1130
Product Id: 6801
Revision Number:  3.02

Config Number: 1
	Number of Interfaces: 1
	Attributes: 80
	MaxPower Needed: 100mA

	Interface Number: 0
		Name: usbhid
		Alternate Number: 0
		Class: 03(HID  ) 
		Sub Class: 00
		Protocol: 00
		Number of Endpoints: 1

			Endpoint Address: 81
			Direction: in
			Attribute: 3
			Type: Int.
			Max Packet Size: 8
			Interval: 10ms

In the setup I have no idea what to do for a comport. In the USB to Serial I’ve put /dev/usb/hiddev1 but what do I do for the comport number? I’m also kind of confused about what it means by usb to serial name.

Does the software not read directly from USB to I need to get an adapter to turn the USB to serial?

I’m so confused! Can anyone help a new guy?

because its usb, there is not com port number to select
just select the irox station type and tick use direct
then restart WD
but also you will need to run it as root too

I’ve edited to skip the root check and I can now start up as root. Doing this I don’t get USB errors in the console.

In the Control panel/ Weather Station Type Selection under 2310/Irox/3600 I’ve selected the “Irox/Honeywell” option. I do not see anything that states “use direct”. Where do I find this option? I’ve poked around but cannot find it.



ok, that direct mode is only on the windows version
try running usbreaderirox
from a terminal window and see what shows there
also, what is the barometer reading showing on the irox console?

I don’t have usbreaderirox anywhere (I looked all through the wdisplay directory).

The barometer reading in WD states 29.914 in (while the actual reading on the unit is 29.212).

Thanks for your help!

getting confused with the Mac version now
ok, next
go to view, ftp log
then click on close
then you should see the irox raw data window
what shows there

I don’t think the program is even seeing the unit. In the Irox log I get:

rolling the data
baro 1010.7
255 10

That’s it.

I’m using /dev/usb/hiddev1 in the setup. Should I be using something else?

When I plug in the unit I get the hiddev1 but that quickly disappears. It almost looks like the unit gets disconnected from the system.

something is happening…as its showing the barometer value…
is that the correct value? (hpa)

No, that barometer value is incorrect.

Issuing lsusb I get the following:

odin@server:~$ lsusb
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 006: ID 1130:6801 Tenx Technology, Inc.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

This is the only usb item on the system and it’s showing it as Tenx Technology, Inc.

When I start up WD I get a window that states “Irox/Honeywell data history”

This then shows:

Looking for data from 17:45:00 11/23/08

***write 152 0 0 0
USB port opened OK
***write 152 0 0 0
***write 152 0 0 0
amount of data =-1
amount of data =-1
amount of data =-1 (this is repeated endlessly)

You are right that the baro data does change a little bit in the irox history page but it’s odd… sometimes it says 33 and now it says 1010.1. I’m really puzzled by all of this!

rolling the data baro 1010.7 255 10

just tested here with my irox station on the linux version…
I get a 10 10 instead of 255 10
so that must be the problem (as use that as a data marker)
i willsee about changing that

i will get a new version uploaded tomorrow that allows that 255 value
just doing a soak test overnight…found a couple of problems with the irox routine.,…

Wow! Very cool!

Thanks for all your help!!!

Ok, my test run overnight worked great
a new QT update is ready to download now :slight_smile:

I’ve used the new version and I’m still in the same situation. Each time I startup I still see:

First time use, setting time/date to get data from to enable all the data to be extracted
Looking for data from 13:53:00 10/24/08

***write 152 0 0 0
USB port opened OK
***write 152 0 0 0
***write 152 0 0 0
amount of data =-1
amount of data =-1
amount of data =-1
amount of data =-1 (this fills up the rest of the screen)

When I close this window and go to the main window nothing updates. There is some data in there (the barometer shows 29.914 in, which is not correct) and it down incorrect temperature values for many items. These values never change.

In the view/FTP Log/Irox menu:

When I click “Openirox” I see (on the left hand box):

Opening USB port 1

On the right hand side of the window I see:

rolling the data
baro 1006.9
255 1
(that baro number seem to be correct)

When I click “Get irox data” it says:

decoding data -1

The right hand box does not change.

I close this window and the main screen never changes.

Argh! What else can I do to debug for you?

first, for now, turn off the data logger switch, under control panel, data logger setup
( I will check on why the missed data history is not working)
next problem, the key check numbers you get has changed for you
from 255 10
255 1

I might have to do away with those…

Looking at my previous post it appears the “0” was left off the copy/paste. I believe that should have been:

255 10 and not 255 1.

I’ve shut off the data logger.

Still no updates on the main screen. The only think that changes is the baro reading on the Irox log screen.

it should be working then
are you sure you have the latest update?
what build does it say under help,about?

I’m using version 10.37j build 14.

My weather station displays both local and sea level pressure. The sea level pressure is calculated based on an entered altitude and measured pressure. The value of 1006.5 (what it’s showing in the irox screen at this point) is the same as the calculated sea level pressure as shown on my base unit. They are communicating in some way but nothing shows up on the main screen. All the values there make no sense and it does not have any of the correct pressures.

While browsing to different windows I occasionally get this in the terminal window I use to start up the program (but I wonder if this is more QT related?):

TApplication.HandleException Access violation
Stack trace:
$0809C5B5 TAPPLICATION__DOIDLEACTIONS, line 830 of ./include/
$0809B3F6 TAPPLICATION__IDLE, line 310 of ./include/
$0809CACF TAPPLICATION__HANDLEMESSAGE, line 976 of ./include/
$0809CDEF TAPPLICATION__RUNLOOP, line 1086 of ./include/
$08AED923 TQTWIDGETSET__APPRUN, line 151 of
$0809CDAA TAPPLICATION__RUN, line 1073 of ./include/
$080591AB main, line 229 of WeatherD.lpr

that will be the problem I think, that access violation
is the time on the main WD screen updating
try the normal GTK version, as that one ran OK for me overnight
(although I am running the QT version now, and its updating OK)

I would also try starting over (i.e delete the settings files (WDISPLAY.INI and wdisplayftp.ini (when wd is not running))

Still no luck… On my AMD64 server I have errors running the GTK version (missing library) but on my 32bit system it started up but gave the same issues as with the QT version.

I found a post about this same weather station in the mac forum. Here was the solution to the discussion (is any of this pertinent to the linux version?):

Hi good news with the Irox Yves has found out the problem the problem is the IOProbescore needs to be deleted from the irox ketch then reload that and then remove and then re insert the Irox usb and then it should work OK Smile

(Yves is working on some other things to improve the USB on the Mac, but for now, the above will work)
(next update of the Mac version will have the updated ketch file , if you cant do that delete yourself)

good work Yves!