Metar ftp and automatic update barometer and humidity

Hi,

I’m using a Dallas 1Wire WS v3. Unfortunatly I’m unable to buy a barometer and a hygrometer at the moment.
I tought that I could use the values wich are obtained from the Metar files. My weather display doesn’t do anything with this metars altough the options are set in the FTP/Metar configurations to use the barometric and hygro values from the metar.

The metar file EBBR.TXT resides in the \metar\ directory and is refreshed every hour by FTP transfer from NOAA websites.

Do I need a decoded metar or just the coded one ?

What did I do wrong ?

WIth kind regards,

David Thijs
Lembeek
Belgium (Europe)

Hi
export and email me your wdisplayftp.ini file from the registry
(see here:
http://www.weather-display.com/exportregistry.html)
for how
and your wdisplay.ini file from c:\windows or c:\winnt
and i will look to see what is going on

ok:
i have your settings:
untick use this metar to update weather display settings…that one is only of no weather station
but leave the humidity and barometer updating working
now, the problem is that WD is using the first metar in the list to pull the humidity and barometer values out from
he solution is to put that metar you want to use as the first in the list, until i fix that :slight_smile:
(you can see its using the humidity reading from the first metar in the list, i found with testing)

Brian,

I did what you have told me, here is the log from the ftp:
I’ve tried with noaa websites and hamweather, both stop at the line where it states “doing metar download now”. There it hangs about 5’, then I get the 301: Interrupted message.

I’m not using any firewall nor the windows xp firewall.
In the connections Tab of WD is the permanent connection marked, the other settings are default.

My ISP obliged me to use a proxy server. For http, it’s proxy.pandora.be:8080
It works fine with IE and Netscape. No other program has difficulties with http traffic. Most other programs do have a field where I have to put the proxy server and port.

Ftp transactions in WD work just fine. I can download a metar without any problem, but the program doesn’t use the metar that I have added manually.

A trace in a ip monitor gives me the following:

Protocol Local Adress Port Remote adress Type
TCP DAV1.pandora.be 3781 hamweather.net http-www

Satus Process ID
SYN_SENT ftpupd.exe:3656

This is the log file:

Permanent connection selected
Permanent connection, will do ftp now
Checking for what else to do…
there are 1 more things to do
Next file HTTP metar station download
http://www.hamweather.net/weather/current/EBBR.html
Downloading to :h:\wdisplay\metar\EBBR.met
final download setting=h:\wdisplay\metar\EBBR.met
Doing metar download now
301: Interrupted.
Finished downloading metars
Finshed email agenda
Finished email agenda, no ftp items to do…
Doing abort procedure/program close…

i will add where you can set a proxy port, etc

Brian,

Thanks a lot, my isp won’t let traffic trough http port 80.
So this was my only option !

Brian,

Sorry to bother you again, but the proxy field doesn’t solve my problem.
I will send you a mail with some screenshots and a little explanation of my tests.

Greetings from Belgium,

Hi all,

I’m happy to say that Brian solved the problem.

He added two fields in the ftp/metar setup where you can put a proxy server and his additional port.

Ftpudp must be version 6.85 to work properly ! :slight_smile:

Thank you Brian !