METAR Download Problem

I’m having a METAR download problem. I know the setup is good because I can click on “Test”, and I successfully receive the METAR CYHZ.TXT.

But even though I have the schedule set to download it every hour, or any other amount of time, it never downloads. Only comes down when I click on “Test”. Any suggestions?

Most likely you do BUT do you have the Main Internet Switch On under FTP - Connections?

The other thing is when you click on Test does your Firewall ask permission and if so have you ticked to remember the permissions?


Yep, it’s on. Just FYI, my WD PC is also my webserver running apache. Firewall is on, but doesn’t ask permission. Can’t remember if it ever did, but either way I see FTP and ftpupd in he exceptions list, and I can run a command prompt on the WD PC and use DOS ftp to connect anywhere I want with no trouble.

Forgive the obvious but do you have the “metar” switch set to “on” and did you select a metar download directory?

Affirmative. Have tried HTTP Download, FTP Download, and Passive FTP Download. It’s as if the scheduler isn’t paying any attention to the schedule I have set, no matter what combo I try, and so only works when I force it with “Test”…

In one of the FTP Screens is “Use WD’s own FTP” is that ticked?


You gave a number of combinations but I need to ask if you have the “times to download metar” set.

Also in the View panel under metar images do you have “show image” checked

No, because I my WD server is also my web server, so its all local. That same tick box says “untick to create files locally only”, which is why I have it unticked.

Yes, I originally had it set to download every 10 minutes. Have tried every 15 minutes and every hour. Same thing.

You lost me on the second part. In “View” under “Metar Images” all I have is the option to set image, change font colour, or change background colour. There is no “Show Image”

If I am not mistaken some problems in downloading have been as a result of that.

I would try ticking “Use WD’s own FTP” and watch and see what happens…


Have you got the tick box: “Still use ftpudt.exe for everything except normal uploads” ticked on? (See screenshot below:)

yes, you will need to have that setting ticked as well that cirrus has pointed out :wink:

Roger that. Will give that a go. Tnx…

Thanks guys. That did the trick!

another half a day gone already on the forum , and very little time so far today to work on WD
oh well
(and I even had someone ask why I had not produced a detailed help manual yet)

It does seem that you are caught in a bit of a Catch-22. If you had a detailed help manual, it would probably cut down on a lot of the questions here on the forums that you respond to, but you can’t get enough time to write the manual because you are answering so many questions that a detailed help file might cut down on (plus there are the WD software updates you do as well).

I don’t envy your situation! 8O