Mac "Solar sensor in a jar" issues - (Resolved in build 15)

Hi, I just set up my solar sensor in a jar :). I have all the settings checked and sensor number 2 selected (it was the inside temp/humidity sensor before) I am not seeing any readings in the current readings tab (current raw or %) , regardless of what sensor I select. So question is am I selecting the right sensor or what am I doing wrong? Also I don’t know where to relabel the indoor sensor to solar. Any help is appreciated.


My screen dumps re above:

Main Screen.jpg

SIJ Setting.jpg

Current reading.jpg

OK I’ve tried all 3 available sensor settings and still no raw readings, no output on main screen other thn the indoor temp still being reported (very high when the sun comes out lol)

Windy, can you confirm Solar sensor in a jar is not working yet in the Mac version or is my set up wrong?


If it used to be a temp/hum sensor then i might be wrong here but shouldnt
you have the “I have an adapted temphum sensor, temperature is solar direct” ticked as well?
In the solar setup screen shot above…

Duh… that’s what that meant! … ok I checked that. Is the sensor number relevant at all now that I checked that? If so, what number should it be for that “temphum” sensor?
(jeesh… I thought that was a brand name… nooooob here)

I think that’s the setting for Mick’s modified sensor, so you would not need it checked for the temp in jar setup.

Thanks guys,
Does anyone know the sensor # I should be using? As stated above, it is the indoor sensor that came with the wmr968. (Although I really don’t think solar is functioning on the mac yet, it would still be helpful to know once Windy helps me get this running.)

I’m not sure that WD will allow you to use the main indoor temp/humid sensor for a solar in a jar setup. I am using one of my 3 'extra temp/humid sensors for my solar in a jar. It is on channel one on my OS968. On WD it is channel 1=solar in a jar , chanel 2= humidity in my jar, my second sensor, channel 2 on OS968 is channel 3 on WD=temp and channel 4=humidity 3dr sensor is channels 5 & 6 on WD.

Under Control Panel > Solar Sensor, have you tried channel 0? I’m not shure what that one is for?


Just for the input, I have an Oregon THC238 as my “Sensor in a jar” it is set to channel 2 andI have no problems, although I have the box ticked that was mentioned before, “I have an adapted temp. & humidity sensor” had no troble with the set up.

The only problem I had was to determine what figure to set the 100% to.

Thanks all, my unit is the BTHR968 indoor temp/humidty Baro sensor. Haven’t got it working yet, but this may be a WD Mac issue not related to settings. I appreciate the advice though, I wonder if anyone else has this sensor working as a solar sensor, on any version of WD?
Thanks for the quick replies,

Correction: I now don’t think this is a WD issue (at least until I get a correct sensor) A lot of reading and snooping around leads me to believe that this indoor sensor was never meant for use as a sensor in a jar, not only as a design issue, but also that is occupies channel 1 on the WMR968 no matter what I do to try to get in onto an extra temp channel. (Then I could select it as a ch 1, 2, 3… referring the the extra temp channels in WD)
Windy, am I getting this logic right?

So, sorry bout that! I have one on order should be in next week. Will update you all if it’s working as a solar in a jar on WD Mac when I get it.

OK, I have a new THGN123N and it is working fine. It registers on the WMR968 console. I have tried to select it as channel 1, 2, and 3 in the control panel/solar sensor/sensor in a jar tab. On the main window there is only the black square that says solar 50%, and nothing in the raw readings tab.

Also, I know it is being seen by WD as a temp sensor because I can get it to plot on the graph in the main screen as extra temp 4 as in the pic below.

Where do I go from here? Any help is appreciated.


Jim, I’m not sure that the Mac settings are the same, but, this is what I have found that works for mine. Go to Control Panel > Solar Sensor > Solar Sensor in a Jar Setup. Select sensor number(4 in your case) For mine I have set 1.1 as a low, and currently using 15.0 for a high threshhold. You will have to ‘play’ with these settings based on your location, time of year, etc. Next, click on the Max Solar Time of Day/Time Zone/Lat/Long Tab. put a check by Update the solar value from max. reading… Set your Lat. and Long. this is IMPORTANT! Put a check by use this new Calc.
set your time zone(also important).
optional… put a check next to Always show max solar for time of day instead of indoor Temp.
you can use the time of day offset if needed if your sensor is in the shade in the early morning or late evening.
hope this helps get you started.

Thanks for your help Bill. I can only select sensor # 1, 2, or 3 in the Sensor in a Jar setup ion the Mac version. Maybe thats the problem?
I set all the other settings you suggested, but nothing yet.
Hopefully will hear from Windy on this… might just be that it’s not implemented yet?

That selector goes to 9 in the win version.

Jim, What are your extra sensors 1,2, and 3 being used for? To move your solar in a jar sensor(extra #4) to one of thes, You MIGHT be able to turn one of them off(remove batteries) change the channel on jar sensor to 1 and your other extra sensors to 2 and 3, reset console, etc. That MIGHT move it in WD to a useable number for it to work as a jar sensor. I don’t know if that will work or not. If not, I would bet that Brian can/will add the ability to use extra sensor #4 for a solar in a jar setup. You might have to wait a day or two for him to find the time to do it. I have mine working pretty good now,as far as I can tell. It took a couple of weeks to 'tweak the setting so that everything looks realistic, but it was worth the time.

i missed seeing this thread
it should work on the mac version (now that you are using a separate temp/hum sensor)
post your screen shots of the settings again and current data for the extra temp/hum sensor

we will get there…(it might mean I have to update some code from the windows version)
have to head out now for a bit (soccer practice for the 6 year old)

Yippy! there’s the boss! Thanks Windy, for a while I thought you were getting tired of me here with all the little mac things that go bump in the night! :slight_smile: Thanks for helping me out here … and Bill/Niko too.

OK the scoop is that this is the only extra temp sensor I own. It is in the temp 1 position (extra) on the console, and registers as extra temp 4 in WD Mac. But the selectors in that tab only go to 3… so I can’t select it as a sensor for the solar. (My head hurts now lol)

I will post the screen shots again but they haven’t changed from above. Here goes:

Picture 1.jpg

Picture 2.jpg

Picture 4.jpg

and this last one:

Picture 5.jpg

Jim, Looking at your settings, everything looks ok except for screen 1. uncheck ‘i have an adapted temphum sensor.’ I believe that this setting is for a MODIFIED temperature sensor, and not for a solar in a jar sensor.