High CPU usage with last few versions using 1-wire station



what do you have set as the polling dealy for the wind direction/temperature
try setting it as 30 (then click on save reset)
also, have you seen, in the latest version of wd, i have tidied up the dallas 1 wire setup
also, which version of wd are you using (you dont actualy say)

Where is this polling delay set?

Yes I did see the house cleaning and I like it.

its the very bottom setting on the extra/misc tab
set it as 30, then click on save/reset on the main setup page

For what it is worth, making the change from 0 to 30ms dropped CPU usage a factor of three here.
It was typically 10-30% and dropped to under 5 % according to WINDOWS system monitor.

Unfortunately, this isn’t a clean comparison since old numbers were with an older version.

Screen rewrites are still typically near 100%.

Henderson, NC