Has 1 Wire reader changed between build 46 and 52? [RESOLVED]

I have been happily running on 10.37Qbuild46 for some time now and the 1 wire reader has worked fine, reading all my 1 wire temp sensors, solar sensor etc.

Yesterday I changed to build 52 and now the 1 wire reader consistently will not pickup all of the hubs - (Hobby Board Master Hub) - picking up hubs A,B but not C. When I initially start up it does, then loses hub C within a few seconds. When I change to other 1 wire readers I have they read these hubs fine no matter how long i run these programs, so I know there is nothing wrong with my hub or sensors.

Brian has there been a change to the 1 wire reader between build 46 and 52? Unfortunately I cant go back to build 46 as I deleted it before I noticed the problem outlined above (do you have old versions archived Brian).

I would appreciate your comments Brian.



Was just about to report a similar issue but decided to do a search first to see if anyone else has see this.

WD 37Q52, Dallas1wirereader.exe V4.1, file date 6/19/11
I have a Hobby Boards 6 channel hub. On channel 3 (Main) I have a leaf sensor from HB. If has been working flawlessly for over 18 months. I just installed WD 37Q52 and noticed that channel 3 (Main) was not reporting properly.
It reports .0047812500 on program start and all three channel lights scan, but after two readings the system rescans the hub (all 3 channels (M and A)) then after that it does not scan (no light) channel 3.

WD 37Q47, Dallas1wirereader.exe V4.1, file date 6/19/11
Same issue

WD 37Q44, Dallas1wirereader.exe 3.51, file date 5/23/11
No problem. Scans correctly after start up and reads .00578750, of course this varies depending of the sensor wetness.

I tried several version prior and all worked great.

So something happened between Dallas1w…exe version 3.5 and 4.1

Running windows XP Pro 2 gb memory, Pent 4, 32bit

the problem will be with the re scan on start up (which someone needed that to happen)
I have that now not occuring now if a hub in use
build 4.2


Loaded up your zip file. No joy. Still does not poll and read all of the hub channels.


thats strange

what shows in the debug window? (tick to enable debug messages)


Have ticked the debug window. What do you want me to tell you - about the stuff scrolling down the LH window or whats in the centre window - not sure which one you mean is the debug window.



Since my previous message, after numerous restarts I finally have it reading all my sensors. The number of times I had to restart WD to get this to happen suggests to me that everthing is still not kosha yet. Seems there could still be a timing issue with the hub polling?!?!?!?


restart WD or restart the 1 wire reader program?


I did a bit of both - but as I said it is working now. Mysterious heh?


All is working now with 1wire using WD 37Q54. Scans correctly.

Spoke to soon… It is doing the same thing noted in my first post. Stops scanning (reading) port 3 (C) after a short time.

Tried the 1wire exe file from the line above but same problem.

I have gone back to 37W44 and again, all works correctly.

which version of the 1 wire reader were you using?
also do you really mean version 10.37w?

Sorry the W was a typo should have been Q. My first post (2nd post above of this series) is correct and discribs the problem.

I have go back to 37Q44 as it has Dallas1wirereader.exe 3.51, file date 5/23/11 which works.

Dallas1wirereader.exe versions after this cause the problem, IE skips looking at port 3 (Main/Aux).

As a workaround, I am unable to use recent versions of 37Q like 37Q54 and then copy an older version of Dallas1wirereader.exe in the c:\wdisplay directory. The 1wire program will start but stops quickly. I assume it is not registred correctly.

P.S. I will be away until next Monday so will not be able to reply until then.

I think the problem will be where I had it re checking for sensors after start up
but I have stopped that re scan from occuring if a hub in use
did you try the latest version? (vers 4.2)

I will run a test here with my hub tomorrow

Sorry for the delay, have been on vacation.
Have been using 32Q57(c) [third upload-July 19th] for about 7 hours and all is working great.
Looks like that did the trick.

Thanks for your work on this issue.