Getting wxsim forecast on PWSWD

Hi. Could you please advise on what I need to do to get my pwsWD dashboard to show my wxsim forecast. I cannot find the path in the settings to allow me to do this.
Thank you.

Hi alienburt,

It is not clear to me what your problem is.

Your debug-dashboard . . .
shows correct working scripts for both the block and the pop-ups. Albeit with very old data
WXSIM text forecast for Burnaston, initialized at 13:06 27 Dec, 2019
You can check here: that the scripts are using the files in the root, which is the most often used location.

The PWS_Dashbnoard uses a copy of the “standard” Saratoga scripts, but to not cause problems with your other wxsim scripts they run from the pwsWD/wxsimPP/ folder
The settings for the location are in . . /pwsWD/plaintextPP/plaintext-parser.php line 133 which reads
$plaintextFile = '../../plaintext.txt';
That …/…/ causes the script to read two folders down from /pwsWD/wxsimPP/ which is the root.

You have to adept that line to point to the real location of the plaintext.txt file.
It seems you have the wxsim files in /wxsim/plaintext.txt
So probably changing line 133 to
$plaintextFile = '../../wxsim/plaintext.txt';
wil give correct results.

Thank you for testing the PWS_Dashboard and success with using wxsimpdata for the forecasts.


Thanks Wim - I do appreciate your help.

I have changed the location to $plaintextFile = ‘…/…/wxsim/plaintext.txt’; but it still seems to be using the plaintext.txt file in the root directory (which dates from 2019).

Any other suggestions as to why this is happening?

Many thanks

Well, it is working correct when I visit your website.
Maybe you are using Cloudshare or another caching server?

So problem solved for me.
If you still can not see the correct data:

  1. Test on another device, preferably at your neighbours internet, that should work
  2. Check your cPanel
  3. Ask your provider

If you need more support after a problem is “solved for me”, mail me with your “Thanks to name/email-addres” and specify your FTP userID and the (temporary) password.
I need to look inside your system, why it is not refreshing in your case while it is refreshing / reloading when I visit your website.


Its working for me now - weird!


Best regards