Getting cleintraw.txt from WD-Linux to WDL on same box without ftp

I struggled with configuration of WD-Linux for days trying to get it to write the clientraw.txt files directly to the folder used by the web server for use with WDL (/srv/www/htdocs/wdl).

OK so I guess most people would use the built-in ftp to just copy the files from the wdisplay/webfiles folder to the wdl folder, which is fine of the wdl web-server was a different box but it should be easier on the same box right?
(Even tried manually editing WDISPLAY.INI but still wudn’t work)

I searched through dozens of posts on this site but did not find the work-around I wanted so here’s my method.

Only a couple more tweaks and this thing will rock.

How to link clientraw.txt files directly to the WDL web-server:

  • WD-Linux clientraw.txt files in /home/username/wdisplay/webfiles
  • WDL web files in /srv/www/htdocs/wdl
  1. Create Symlinks from the WDL web folder back to the wdisplay/webfiles folder where the clientraw.txt files want to reside:

cd /srv/www/htdocs/wdl

ln -s /home/username/wdisplay/webfiles/clientraw.txt clientraw.txt
ln -s /home/username/wdisplay/webfiles/clientrawdaily.txt clientrawdaily.txt
ln -s /home/username/wdisplay/webfiles/clientrawextra.txt clientrawextra.txt

  1. Add FollowSymLinks option to the wdl folder:

cd /etc/apache2/conf.d

pico wdl.conf
(new file wdl.conf shown below, you can copy-paste into pico with Shift-Ins)

Enable SymLinks for wdl folder

<Directory “/srv/www/htdocs/wdl/”>
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all

(restart apache to load changes)

you should be able to set the clientraw location in the WD linux version yes?
i think i fixed a bug with that,in the latest zip update…?

Sorry Brian, no…at least not that I can figure out. I really wish the Linux version was as slick as the Windows one.

See attached screenshots showing the setup (control panel) screens for both versions.

  1. The Windows version lets you select a DIRECTORY location for the clientraw files, separately from the webfiles location. I can see this in the registry entry NEW WEBFILES LOCATION which has separate entries for clientraw location, and location (webfiles).
    You can see where I easily set the clientraw to write into my mapped ‘W’ drive on the Linux server.

  2. In the Linux version there is only one button to select ‘web files location’.
    This button opens a file browser (see attached jpg) looking for a filename not a location (directory).
    If you try anything other than “./webfiles” (as in /home/username/wdisplay/webfiles) an error message appears saying "Cannot Read Directory ‘.//webfiles’ ".

In WDISPLAY.INI I believe the section is called:
[Files new]

As mentioned, if this is anything other than ‘./webfiles’ the error message puts up.

Let me know if there is a way around this. Its very confusing in the Linux version with 3 control panels
that mention clientraw.txt but none that seem to let me set its Directory.


go to the ftp/internet setup, client/server setup
and there you can set the location for the clientraw file
(bottom right hand corner)
try that

but then restart wd to properly set that new clientraw location

Hi Brian, please read my note again.

In FTP/Client-Server setup, when you click on the button “Set location for clientraw.txt” a File Browser window opens and expects a FILENAME to be entered not a DIRECTORY (as in Windows version).
So my guess was to browse to my web folder and enter ‘clientraw.txt’ in the FileName box which enabled the ‘OPEN’ button, click on that and the browser screen closes. Ok so far but it doesn’t work.
Sometimes it ends up writing a new WDISPLAY.INI in the folder I chose, sometimes it does write clientraw.txt there…once (never updates).

If I come back to that setup screen and click on the “Set location…” button again I get the error message mentioned before "Cannot read directory ‘.//webfiles’ .

  1. So how do you use this button/file browser window to set a new location that will work?
    (eg /srv/www/htdocs/wx instead of /home/username/wdisplay)


the ini files should have
[New webfiles location]
client raw location=

make sure that is set correct?

Brian there was such section in my WDISPLAY.INI.
I shut down WD, added those lines using pico and restarted WD-Linux.
No difference, I still can’t set the location.

You didn’t reply to my original question about how to use the “file browser” to set clientraw.txt location when it s looking for a filename to OPEN not a DIRECTORY to set.

Oh well, this was not a big deal, the work around with SymLinks does it for me.
Lots of other bugs to squash first. Going flat out on this project for past week or more but getting close.
I really hope the Linux version gets to be as good as the Windows one as I surely don’t want to go back to use Windows apps for WX and this is the only decent Linux-WX program I’ve found. Thanks for all your support.


when you select a file (any file will do),in the directory you want to use, the directory is included as part of the file…and then WD strips off the filename you have selected and what is left should be just the directory
i will do some testing here…
note, been out all day, cooking sausages for PTA (600 sausages!)