FTP UPDATE schedule not working

I can cause an update by going to action and selecting update internet. However the set schedule of every 10 minutes does not deem to be updating the file on the remote server. Manage FTP webserver also works to update files.
Any suggestions appreciated

make sure the main internet switch is on in the connections setup in the FTP/internet setup
and you have ticked, use weather display’s Ftpupd.exe
also if you have the switch on in the customise internet and file creation setup then make sure you have set times to create and times to upload for each file needed, and the create and upload switch on for each file needed, and the correct remote file name as well

Brian the problem is with the name when I use advanced update If I use PinawaTown.htm it does not work if I use Pinawa.htm it still does not work but if I use Pinawa.html it works fine. sounds like the old DOS 8 character problem with the name not sure about the suffix. Thanks Grant
PS sorry to hear about Christ Church following it here in Canada

also just npticed if I try to change the name of Screen image file file from Pinawa.gif to PinawaTown.gif in Custimize Internet and File Creation set up it will not change in the up load as I watched the FTP and on remote site still Pinawa.gif same as HTML Table. I

if you are using the customise internet and file creation setup, then make sure to set the correct needed remote file names in the upload times
also, you do not normaly add the .htm or .html to the weather station file name in the webfiles/web page setup
that is done auto (via the setting to use .htm or .html)