FTP Problems - intermittent irregular CR upload

Moved from the Steel Gauges thread as it also affects CR updates…

I’m having FTP problems. The live CR upload is set to go every three seconds, but works erratically, and only intermittently. I have checked everything I can, and no other files are being uploaded. (I have disabled CCR for now until I get this fixed.)

Brian - I appreciate that this may well not be a WD bug at all (and probably isn’t!), but I wasn’t sure where else to put it.

This problem only started after I moved over to a new computer/router, and after upgrading to the latest version of WD. I would have thought that with a better router, faster PC, upload would be more reliable (and it was fine before on a creaking old PC with an old router). (Upload is to the same web server as before.)

Clearly something is verywrong, but I am unable to identify what it is. Until I do so, my live weather site is pretty useless, so I’m really hoping that someone will at least have some suggestions.

Many thanks in advance.


The first place to start is with the FTP log and what it’s showing when the FTP upload fails.
Also check View > Program Debug Info to see if anything shows in there.

As you’ve changed the PC & Router then I wouldn’t mind betting it’s something to do with a setting in one of those, otherwise a few people would have reported issues along the same lines with the latest build of WD. :wink:

ideally need to see the real time ftp when things are not updating correctly,etc

also make sure there is not like a second version of WD running or similar

Thank you for the replies - I do appreciate it. When I next go down to my sailing club where the PC is based I’ll be sure to check the logs. I did check the real time FTP info and it doesn’t report anything - it just stops. Oh - sometimes it says “busy with previous…” or similar.

I did some more testing yesterday. I reinstalled WD - no effect. I disabled firewalls - no effect. I tried the connection with a different router (the old one which used to work fine), and the problem was the same. I tried uploading to a different web server - same problem. I tried connecting to router using both Ethernet and WIFI - again same problem. I also tried test uploads using FileZilla, and again there were problems, with Filezilla intermittently reporting ECONNREFUSED.

Clearly this is not then a WD issue, so my apologies for initially posting here. That said, if you or anyone else have any insight, I would be most grateful. We even brought down someone with more knowledge of FTP and he said he had never seen anything like it!

One thing we tried was to tether the PC to a mobile phone and connect to the internet using mobile data, thus bypassing both router and broadband link. At this time the FTP appeared to work better. I’m not entirely sure as sometimes it works for a few cycles anyway before stalling. Strange though. Ruling out router, this would imply a broadband fault, but we have video streaming that works without a hitch and of course uses a lot more data that the CR upload. Plus we had a broadband guy check out the connection, replace cabling, and it’s all good.

I guess ruling out everything else points to a fault with the PC or OS, but it was a new installation after a clean disk wipe with no problems.

You can see why I’m stuck!

do you have set to use passive mode?
if not try that

Yes I’ve tried with and without passive mode.

Brian, IQUEBECS58 reported that switching to an older version of the ClientRaw FTP program cured his FTP problem. Could you tell me how to get hold of an older version so I could try that?

his particular problem was that after changing to the remote directory , it did not then carry on and upload the files
that is not the problem you have
so not sure why you posted in that thread

My mistake - I didn’t fully understand. Just clutching at straws trying to figure out what’s wrong.

It’s so strange - my CR uploads but maybe once every 15 minutes approx on average.

do you see the link to the older clientrawrealtimeftp.exe I put in my post above that you asked for?

Thanks Brian. I’ve just tried this and it’s working better. Firstly, when I first started it old FTP program up, it uploaded successfully for about 10 cycles before stopping. But then, rather than simply hanging, it closed itself down and restarted. Although its now not uploading as many cycles as it did first up, at least it keeps restarting so I’m getting the CR up more frequently, although admittedly no-where near what it should. I’ve also re-enabled the Gauges CCR upload HSSC Weather Gauges

Attached some FTP logs which might help:

– FTP-REAL-TIME: this is a few copies of the info display from the older FTP program I started running today.

– ftprealtimelog-OLDFTPPROG: this is today’s log using the older program you supplied. As you can see it does seem to stall when uploading the ‘extra’ or ‘hour’ files - but I might be wrong on that.

– ftprealtimelog-1: This was the log from a few days ago when I was running the newest ftp upload software. Those error messages by the way didn’t always occur - sometimes it would just stop without any message.

Thanks again.

ftprealtimelog-1.txt (1011 Bytes)

couldn’t seem to attach

ftprealtimelog-OLDSFTPPROG.txt (1.2 KB)


FTP-REAL-TIME.txt (2.38 KB)

its not very clear
which log file is from which version?

ftprealtimelog-1.txt is from the latest version of the software, the other two files are from the older version (the version you gave me a link to above).

FTP-REAL-TIME is just copied from the window of the running software.

so you are getting this error

Error Could not open a connection bound to a specific interface, trying INADDR_ANY with FTP transfer
(which I have not seen before) if you could email me your FTP settings, I will test here

Will do. Although as mentioned I did try the CR upload with settings for a completely different web server, and same problem.

ran a few tests here with your FTP settings , no issues noted, but was not like a long test

Not surprised

At my sailing club weather station I tried a completely different web server