FTP not working on schedule

This morning I updated from a working 9.46a to 9.46b. At that point ALL scheduled updates and uploads stopped. Manual updates/uploads via the action menus dont work either. Test buttons mostly dont work except for APRS and Wunderground which will test just fine.

Tried reverting to 9.46a with no improvement. Same with newer 9.46c this afternoon.

message in progrom error log says:"ERROR: ‘0.0’ is nort a valid integer value at " then the time and todays date. The messages are repeating every minute. FTP log shows ftp trying to run but quiting after 0.02 minutes with no transfer activity shown.

Running a WD server on Win2k Server

Any sugestions as to what could be causing this?


FTP also stopped working on my system after upgrading from 9.46a to 9.46b. Going back to 9.46 did not resolve.

Running WD on Windows ME.

And me as well, Win 2K Professional. Worked fine for about 3 hours, then FTP stopped.

Forgot to mention as I was troubleshooting (restarting WD, rebooting computer, reverting back a version), the VP forecast text stopped appearing on the main screen, in case that somehow helps finding the problem.

My problem with hangs is definitely related to the ftp function. It starts out working and uploading just fine but eventually stops working. How long it takes before it stops working varies from 10 minutes to 10 hours.

Ultimeter 2100, Windows XP Pro, Software firewall disabled.

Right now I’m running APRS Lite whose ftp runs and runs just fine (I don’t think I have a copy of the earlier 9.45 versions to try).

I haven’t tried Brian’s latest suggestion to increase the ftp timeout but perhaps tonight (I was busy installing a new rain gauge last night. Yay!)

Pretty much the same here Ted, only my ftp has been hanging every morning when I send out my 6am email to some friends…went back to 9.43 to see if that helps…

Have done a bit more research on the problem. I noticed that I was getting a program error entry in the log every minute, and that no files in the webfiles dir were being updated.

I turned off all FTP processing and confirmed that program errors had stopped being created. Then I started turning on internet functions one at a time while checking the error log and the webfile dir.

APRS and Wunderground work fine and upload on schedule as before.
FTP / METAR download and Gen FTP work fine and on schedule.
WebCam upload works fine and on schedule.
Web File uploads work fine and on schedule.
The above functions all work together per schedule or from am action menu update.

The following functions were tried one at a time with results as described.

Email Weather Reports cause a “ERROR: ‘1.1’ is not a valid integer” entry and stop all file updates. This happens with “TEST” and with a schedule. This is true with eoither default or custom reports.

Custom Web Pages do not update, cause a “ERROR: ‘1.1’ is not a valid integer” entry and stop all file updates. I have tried commenting out all custom WD tags in wxlocal with no change in results; wx.html is not updated, and error entry occurs.

Using “customize the internet file creation and schedule…” causes a “ERROR: ‘1.1’ is not a valid integer” entry and stop all file updates. Turning it off allows normal scheduled operation.

I have also discovered that if WD is running, I am unable to edit, copy or move wxlocal.html. This was not the case prior to WD 9.46b.


Fred - my compliments on a superb job of troubleshooting! And thanks for posting the results.

I’m having this same problem. FTP will not work even after going back to an older version.


I think I need to clarify what I found.

My problem does not appear to be with the FTP program. It looks to me like something is going wrong during the updating of the files to be uploaded. This results in either the FTP program not being started or the list of agenda items to be empty.

I could see this by looking at the last entries of the FTP error log and the Program Error log. In those cases where the ftp program started, it found nothing in the agenda list. Howerver, in the majority of instances there was a program error durring the file update process.

By limiting the functions to be performed, I have most of the stuff being uploaded, but unfortunately not email reports or custom web pages.

Guys my two cents here. My FTP had been hanging every few hours like said above. I downloaded the “old” ftp from the download page and have been using it for several days w/o trouble.

Going to an older version of WD still uses the newest version of the FTP program since that is what is there now. Replace that with Brian’s “old” version with an independent download. You have to unzip to wdisplay however.


I’d love to do that but I can’t. :frowning:

I need the PASSIV mode provided by the new FTP in order to get anything to work here since my access to the internet is through a proxy / firewall. Been using the new version successfully since it first became available over a year ago.


Thanks for tip.

I installed FTP ver. 5.98 and I’m back up and running. :stuck_out_tongue:

Running XP Pro, WD 9.46c and FTP v. 5.98


Hmmm version 5.98? I downloaded the “old” 11.25 ftp version…APRS and Wunderground are fine but e-mail is still definitely down I keep getting the same invalid integer and I/O errors in the program error file…:slight_smile: I sure hope Brian is having fun on his vacation cause looks like he is really going to need to be well rested when he gets back!

I had the same problem and then reverted the whole shebang back to 9.45e. I thought it was something I had been doing while fixing or at least trying to resolve my java problem.

I was a work and was wanting to view my weather at one point and only the web cam updated. So when I got home I reverted all back , lost a day of data and reverted to an earlier edition (I have been keeping them each revision) .

Glad to find out it wasn’t me but the software. :roll:

Fred, you’re the man! I’ve been running v9.46a all day with APRS ON and wunderground ON and web pages ON but with custom web pages OFF and email reports OFF. The FTPs seem to be occurring when they should. Awesome Good work Fred! This is the first time all week that I’ve been able to run something other then the APRS Lite version for more than an hour. Thanks and oh did I say that was awesome work?!

Hear hear! No email but am running 9.46c and 11.25 for about 7hrs…everything is almost like clockwork. However when I try and update my weather icons I get a 0.0 not a valid integer error in my program error log. Oh well everything is mostly back to normal … :wink: sort of

Thakns for the kind words! But all I did was try to provide enough info to Brian so that he could run down the problem. I know from personal experience the trying to pin down software bugs with only the words “its broken” can be tough.

Bt the way, where exactly in Boston? My wife and I grew up in Charlestown.


We’re not originally from Boston but have been here 20+ years. We also keep moving further and further out to the suburbs. We started in Watertown (Myself) & Brighton (Her), moved to Wayland, then Framingham, and now we’re in Mendon (which actually brings us pretty close to Rhode Island!) Of course the world isn’t familar with these small towns but everybody has heard of Boston!

Version 9.46a is still running into the third day with ftp uploads working for APRS, wunderground, and web pages. I started up Zone Alarm Pro yesterday and the ftp uploads kept running fine. I still have custom web pages OFF and email reports OFF…