Ftp not auto uploading to my website,

Hi all, i’m having some issues with my mac not uploading data to my website, www.ambientnd.com is my site, im getting some updates by playing around, but it doesn’t do anything automatically, this morning it was totally down, restarted WD and got the weather to work somewhat, updated every 5 minutes for about half hour, then was down again, but the live weather update didn’t come up, computer is updating the webfolder, but not uploading anything, i saw a few had the same issue back in 09, but this is a newer version so i figure it’s a setting somewhere that we missed, please let me know, i have limited time today, but will try stuff as you give me tips, thanks in advance,
ohh, Chris is helping me setting it up, (Awesome Guy) just never worked with a mac,


Yes…the Mac version is totally different to me, and I am unfamiliar with the correct procedure for making WD updload the data to his server.

Could use a helping hand as to how we go about making WD send the data to his server at the 5 minute intervals, and also the real time every 5 second updates on dashboard.

everything is on his server ready to be used, just not getting wd to send it there at regular intervals.

we did have it working a little last night, but sems wd feezes up and stops sending the data for some reason.

is there a read me about how to do thiswith a Mac, and where is that readme file?

or is there a good link for mac users somewhere here in the forums.?


we also saw that the files are being created and updated every 5 minutes inside his “”/Library/Application Support/wdisplay/webfiles"" folder…but need instructions on how to make them be sent to the server.


Hi Chris and Spatterfree,

I’m not sure if it will make a difference but in my ajaxWDwx.js file my reference to the clientraw location looks like this: var clientrawFile = ‘./clientraw.txt’; but on Spatterfree’s it is missing the . at the beginning (var clientrawFile = ‘/clientraw.txt’; ) This should also be the same in your Settings.php. Either way, whichever is correct they should match.


ADD: Hmmm, disregard above - it looks like it’s working at the moment, although it is intermittent. It appears that possibly the cronftpreal is stalling. If you open Activity Monitor and go to My Processes you should see the cronftpreal showing activity every 5 seconds or so. If not, something is causing it to stall.

That’s an important dot to be missing 8O

Let us know if you’re still having problems…

updated to the newest version a hour or so ago and everything seems to be working good so far.


Hi Chris,

I see that Spatterfree’s site is down this morning. A while ago we had an issue with testtags, some of the snow tags were causing lock ups in the clientraw being updated and ftp’d properly. Just for a test, here is a copy of my testtags.txt, maybe give them a try and see if it makes any difference.


testtags.txt (41.3 KB)

I can explain that outage, we are on a beta internet connection, and they block ports after 10PM to save bandwidth,
but if you can tell me what it needs, they can unblock it for me, let me know what ports it uses, and what i need to unblock,
i’ll try replacing the txt file anyways, i got a copy of they older one here as a backup,

biggest concern is, it should automatically resume uploading, but it doesn’t, seems like it’s not uploading without me guessing around to get it working again,

Hi there, trying to reply to your message but I get an error stating your inbox is full

FYI: New members have very limited PM capacity until they have made a certain number of posts.

if you want to contact him…just go to his website and click on the contact us email link at bottom section of his website. in the footer section of the pages.


Thanks guys - done.

the blocking of the FTP by your ISP is not going to help things , thats for sure

i think we got it going, it really was the port blocking, the software did it’s job, but couldn’t upload,
but another issue i have is i can’t properly shut down WD, if i exit and quit, it never quits, if i shut down, it stops responding,
anything to fix that?

I have not had that happen here
but try killing off the process using application monitor (WeatherD)

Hello Brian…

I logged into his PC via Teamviewer5 program and checked out his MAC version of WD. I also tried doing a Exit-Save and Exit, but it never seems to exit out. shouldnt this be done to save any changed settings upon exiting the software? if clciking on save and exit how long does it normally take your WD to exit out there? we have waiting as long as 2 minutes but still never exits. The only way to exit is to either clcik on the red dot/top left on a macscreen, or like you said in activity monitor.

maybe becaue he has a RainWise WS-2000 station it is causing this?

another question…why doesnt the Control Panel>Wunderground Almanac Icon Feature work in the Mac Version? It only shows list of states down to Connetitcut, but doesnt scroll down any further than that? do you have wunderground alamanac NWS records working on your Mac? or it is still a list of things to do on your future builds of mac version?


Hi Chris, I know you directed your last post to Brian but I thought you could check a few things. I’m certainly not an expert on macs but one thing you can take a look at is the Console which can be found under Applications/Utilities/ . With Console open check the log files - All Messages, Console Messages and System log to see what kind of error messages, if any, may be showing up. You will also see the activity of the mac here. Check this while WD is trying to shut down and maybe something will be evident. I have experienced the same where WD does not shut down too readily and if I remember correctly there was an access violation that was basically streaming, causing WD to become unresponsive. Force quitting is all that worked for me. This only happened a couple of times though, not a regular thing

As far as the RainWise is concerned, I would not expect it to be an issue since I’ve had mine up and running almost 2 years now.

Wunderground Almanac - I have not had success trying to use it either.


the save and exit just forces a save off the current data, but that data is updated regularly anyway, so there is not harm in just using the X to close
its most likely there is an error on exit as mfd38 suggests

re the scrolling boxes, the missing scroll function is a problem with the latest compiler update I did
maybe using a keyboard scroll down might get that to work

Hello brian…

it seems to save any settings as you mentioned, even if the user has to just click on Quit, and not the save and exit.

is there plans to get the scoll working in a future build for mac for the wunderground almanac? tried using the arrows on keyboard but didnt work, also the mosue wheel also didnt do it. it is just stuck on Coneticut and wont go lower. I mention this incase anyone wants to ever use the alt dashboard and have the NWS record data below the stations HIGHS/LOWS Data in same are of dashboard.

another question is…what interval should the logger be set at for the rainwise station is use? it is currently set a 1 minute intervals.

I have never seen myself the station that spatterfree has in use, which is a RainWise WS-2000 weather station, but does anyone know that has owned or does own one if there is a way to manually set the barometer? and how and where that is done on this type of station?

I mention this because spatterfree’s barometer reading was reading 26.xxx when I was logged into his Mac earlier today. I did try the offset and adjusted it as close as possible to other’s barometer readings within his area. for the time being I have it set to get the barometer data from local metar and that s workiing nicely.

one last question…when logged into spatterfree’s mac and watching the WD Main screen…should the wind speed be moving every few seconds, or every few minutes? it doesnt seem to move as frequently as my own davis vantage pro2 wind speed does, but am not sure if this is normal behavior or not for a rainwise station.