Frustrating inconsistencies with rain

I have a Peet Ultimeter 2100. It’s got a Peet PRO rain gauge (1/100 of an inch, or 0.25mm, data collection).

On my weather station console for yesterday I show 41.91 mm of rain was counted.
On the data Weather Display collected and sent to the places I’m serving (Weather Underground and, I’m only showing 16.5mm.

The Ultimeter console is configured to read from the rain gauge correctly.
It is configured to send data out in Data Logger mode.
I see the data “light” flashing on the WD screen and the data quality is reported to be good.

I have enabled the raw data output in WD per my previous thread, but all I get there is a file with a bunch of ‘final buffer’ values listed - I have no idea which is the rain and what units or values it is.

On the Control Panel > Station Type > Ultimeter/Acu-Rite page, there are checkboxes which say “0.01 in rain gauge”, “0.1 in rain gauge”, and “* 10 rain amount needed”. No matter what I check for the first two, whenever the program is launched after the computer reboots, it resets to “0.1 in rain gauge”. First of all - is that 0.1 inch rain gauge, or 0.1 units are in(side) the rain gauge? I can’t find a help file that will explain this to me.

Everything else appears to be working right in my setup except that the rainfall is not reporting properly in WD and to the services I’m feeding. Right now, my Ultimeter console shows 3.56mm, but my WD screen and the services I feed say I’ve only had 1.52mm.

With the Ultimeter PRO rain gauge, what should my settings be in WD?

In WD, I have said that “I have metric rain” (right above “0.1 in rain gauge” on the Control Panel > Station Type > Ultimeter/Acu-Rite page). However, in the Ultimeter 2100 manual, the setting for 0.25mm (step 2, page 28) doesn’t indicate that metric rain will be sent - only step 4 on page 29 (0.1mm setting) states that. Should I be running with “metric rain” set to no (in WD) instead?

I’ll try to get some input/insight from Peet as well, but from what I’m seeing here, all the hardware is working fine - and all the readings coming into the software (WD) are good too, with the exception of the rain data. I feel pretty confident it’s some kind of misconfiguration I’ve done in WD, but I am at a total loss to what the solution is.

Thanks (again) in advance!

Your rain gauge is a 0.01 inch gauge.
0.01 inches per bucket x 14 tips of the bucket = 0.14 inches of rain. 0.14 x 25.4 = 3.556 mm

I see in the Station Type window in WD there’s a tick box for “Rain is at the first part of the data”. Is that the case with your station?

Also; make sure you click the “Close/Save” button on the Station type window when closing it and when closing the WD program be sure to use “Exit” > “Save & Exit” on the top menu. If you close WD in any other way you may loose settings you’ve changed. :wink:

Sorry I can’t help further as I don’t know the Peet stations.

Thanks for the confirmation on the 0.01 inch.

I have tried both “first part of the data” and not, and currently I’m getting some rain showing, as I said, with the “first part” box unchecked, so I am presuming that the rain is at the end. If I remember my last attempt at messing with that checkbox, I got nothing when I checked it, so I think I’ve got that part right. I’d been hoping there would be some kind of ‘debug’ log that would show me the contents of the data packet that the Ultimeter is sending, so I could tell for sure what each data element is, but the ‘ultimeterrawdata’ is in a format I can’t understand (per my earlier post). Maybe Peet can give me an explanation of what each ‘buffer’ corresponds to.

I learned after the first couple of times to always ‘save’ on the control panel/settings windows and to exit the program gracefully. :slight_smile: It’s become habit.

Thanks for the input. I hope to see some substantial rain this evening (local time) so hopefully things will start to line up!

Could you post a screen shot of your station setup window, that may help see if it’s a setting problem?
Something else to check, make sure there’s not rain offsets under Control Panel > Offsets & Initial Rain > Rain Offset
Or you can go to Control Panel > Units & Other Settings > Rainfall Setup.

Also, sometimes it helps to put your location in your profile, even if it’s just your country, as that can effect the response. :wink:

Sure thing. I captured the station setup, offsets, and rainfall:

Oh man, I’ve become that guy. I always fill out my profile on forums and have said exactly what you have said to others. Now I’ve fallen victim to it myself. :slight_smile: Apologies and dealt with!

I took another look at the rawultimeterdata.txt file. Rain showing on the console of the Peet right now is 3.81mm, so based on your earlier post I suppose that should be a value of 15 in the raw data. The file has 15 listed twice, but neither of them are at the beginning or end of the data (buffer 7 and buffer 44):


Note: If you are looking at the station online (WUnderground or CWOP), it will look correct because I just used the offsets page while composing this post, to make the Ultimeter console and WD show the same daily rainfall total (3.81mm). That way I know if we get any more rain tonight, whether or not my current software settings are correct.)

You don’t have “I have metric rain” selected any more. Is that just for testing?

Nice part of the world. We spent 3 weeks touring around there back in 2003. Hired a RV from Calgary and went up to Jasper, then back. We spent the last couple of nights at the Calgary West Campground and went to a Stampeders vs Eskimos pre-season games on our last night. :smiley:

I’ve had the ‘metric rain’ setting selected all week long but turned it off today because I noticed that of the five options in the Ultimeter settings (0.01 inch, 0.25mm, 0.1 inch, 0.1mm, and 2.5mm) only the 0.1mm one says it sends data from the Ultimeter in metric. The others (of which I have set the second one, 0.25mm) don’t specifically indicate metric in their description in the manual.

Yes, it looks like a metric conversion problem…16.5 * 2.54 = 41.91.
I think you also need to check ‘I have metric rain’.
Also on my Peet station setup I use ‘long data lenght’
Keep the ‘0.01 in setting’


Hi guys,

Turning OFF “I have metric rain” solved the problem. Apparently only the 0.1mm setting (in the Ultimeter console) sends the data to the serial port in metric; the 0.25mm setting still sends the data in “English/Imperial” I guess.

Just in time, we had a hellacious thunderstorm a couple days ago and brought our totals up over 80mm for the day!

Thanks to everyone for your assistance.

Glad you got it sorted. :thumbright:

good job guys all round :smiley: