Forum access speed

It will be interesting to see if non-US based users of the forum notice any increase in speed in the next 24 hours or so. There’s a new cross connect to Global Crossing coming on stream today/tomorrow and that should be good for non-US traffic. That connection will apparently be going to 10Gbps in the near future. The plans are to have 50Gbps of connectivity (from a variety of providers) by the end of Q1 2007. I wish I had that kind of connection at home 8O

Jeepers! In the wilds here I had to argue to get the lowest BBand speed.

Pretty quick on the bandwidth side of things from here in Aus, although about 2 hours ago (11:30 pm our time) it was taking several minutes to load each page … there must have been some kind of issue, but it’s fine now. It sure would take alot of forum traffic to get anywhere near even a fraction of 10 Gbps. I guess the server only has a 10mbit or 100mbit burstable connection anyway, but it is good to know that your DC has lots of bandwidth their clients.

btw I read in another thread about the daily backups slowing things down. If you havn’t already tried, you may wish to try using rsync and no compression. You can also put a bw limit in the rsync command line to keep it running cool.

The server has 100Mbps burstable connection. I need to do some more work on the backup side of things soon and rsync will be part of that. Luckily the pair of servers have a no-bandwidth-limit private network between them that’s ideal for this purpose and it also means that I can keep rsync locked securely away on a VPN that no-one can access.

Things might be a bit quicker now. I’d forgotten that I’d left a complete backup set of forum tables in the database after lthe last upgrade. I’ve removed them (and done another tweak) which has shrunk the database by >250MB!

Chris I’m still experiencing timeouts trying to access the forum, there is no rhyme or reason to it! I can load a page real fast, click on a link say to a topic I want to read and I get a timeout then I click on the same link again and it loads fast! This is happening quite a lot too. It is a real puzzle, because it seems only to happen to the forum not to any other pages I regularly browse. As I say the strange thing is in between it is very fast to load!


The change I’ve made should help improve the time taken to save a post. That’s the biggest performace issue I’ve seen.

The problem you’re seeing sounds more like network routing. I see that sometimes, but there are so many hops between me and the server it’s difficult to know where the problem is.

I’m getting the same. Happened again today between 1440 and 1525 (local time, UTC+2). Total server unavailability. No problem with any other site.

I think something crashed, but I won’t know until I can check the server logs this evening. I had to press the big red panic button to reboot the server, but it seems to have recovered pretty well.

I think something happened again today at lunch time, but I only experienced it for a few minutes so I can’t be sure. I’m pretty sure it’s related to MySQL, but as I don’t have easy access to the server when I’ve seen the problem occur (around 13:00 UTC) I can’t confirm this. If anyone sees long outages with the server giving error responses or just unavailable, please let me know what time it happens. It’s possible I’ve got a couple of batch jobs clashing which upset the server operation, but knowing when problems start/finish would beuseful.

I’m just finishing work now for a couple of weeks off, so I might be able to narrow the problem down whilst I’m off and (possibly) available for server duties during daylight hours. However as the problem seems to occur at lunch time, I may be eating rather than server watching (and if not eating thenm child watching!)

I got one Unable to connect to database error this Morning (my time) around 9 AM ET I believe…


9am is about 14:00 here so that was after I saw the problem. I think that was about 1310 local time, or 0810ET.

Too early for me :slight_smile:

It could have been that early… I got to work at 7:45 AM ET checked some stuff and then tried to access the forums and got soem time outs and then an error and then they started working again so that time frame may have been right…


I think I’ve found the culprit. It’s probably been doing this every day without me knowing it. It’s a copy command that’s supposed to back up the database files to the other server. Unfortunately it seems to want to get the complete database image dumps into memory before copying them and this exhausts the server memory and makes things real slow. I’ll put something else in place to copy the files!