Error reading from ASOS on serial port

We have two identical RHEL 7 systems running the latest version of WD (19 March 2022).

One is connected to a Davis sensor via serial and is running great! :smiley:
The other is connected to an ASOS via serial and is giving me an error [ser_read error Resource temporarily unavailable] every second. :frowning:

  • I am able to connect to the serial port and see that data is coming in[screen /dev/ttyS0 9600]. (ScreenToS0.png).
  • The configurations of both systems are mostly identical, except for the Weather Station Type Selection. (StationType.png)
  • If I select the Davis sensor in the Weather Station Type Selection, then the error stops being produced, and selecting ASOS again starts producing the error again.
  • Running weatherdisplay as root still shows the same error.

I am not sure what other troubleshooting I can do, so any help would be appreciated.


wd_log.txt (2.34 KB)

oh, this will be the first time an ASOS station has been tried with the linux version
I will review my code and see if something stands out and let you know

no gaurantees
but try
https://www.weather-display.com/downloadfiles/weatherdisplaylinuxtest.tar.gz

Thanks for the quick response. I downloaded the test version and installed it.
Unfortunately, the problem persists and the same error [ser_read error Resource temporarily unavailable] is repeatedly displayed.

I also found a serial-USB adapter, and tried changing the COM port to dev/ttyUSB0, but that as well did not seem to make a difference.

Are there any other options we could try?

its not a fatal error
its more like a buffer overrun
i.e if you leave the program running, it should eventually clear the buffer
there should be some debug info, under view, debug info and view, program event log?

We tried to just let it run for some days, but the error persists.
Unfortunately, the program event log is blank, and doesnt seem to populate with any data.

It would be nice to get this working on Linux as well, but we are also looking at putting it back onto a Windows machine if all else fails.

checking my code I see I have not set the baud rate
so that is probably the problem
what have you selected as the baud rate?
i can fix that , and you can try that

We have the baud rate set at: 9600 Baud

Thank you.

OK, I also think the problem is that there is a lot of data being sent by this station
and I am not reading enough data chunks from the serial port (1000 bytes) at a time
so I could try increasing that and also add more debug info to see what is happening

Hi
try a new update
I have increased the amount of data read
also added some debug code under view, debug info

Tried the new update. No change yet :?

Here is the debug info:

Loaded all time records
Loaded units
com port port handle /dev/ttyS0 13
#connected OK to com port /dev/ttyS0 13
set the comport OK to speed 9600
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1
data count -1

OK, that shows no data is arriving
is tyS0
the correct port?
(serial port 0)

Yes, I was able to connect to the serial port via screen and see the data coming in.
We tired a few other things to troubleshoot, but in the end it was decided to move the ASOS sensor back to a Windows machine, for now.
Thank you for the support, and we are happy that our other Davis sensor is nicely working on Linux.

always a bit hard to trouble shoot without the hardware :slight_smile: