Ecowitt HP2551CA upload to PWS on local WAMPserver


I’m new to weather stations and PWS and ask that you forgive my ignorance.

I have purchased an Ecowitt HP2551CA, this exact one: ( This unit does not work with WS View.

I have downloaded PWS and installed the same on a local network instance of WAMP, my intentions are to make the weather data available to a small group of users and read the data from a local instance of OpenHAB for use with home automation, (the OpenHAB binding for the station does not work with “no-WS View” models).

I have successfully completed all the required setup including that on the weather station via its IP address:

data = the local host that has been defined and tested as working

The problem I am experiencing is that the weather station does not appear to connect to the PWS instance at all and I am not sure of the following:
-setup issues
-model campatibility issues
-WAMP setup issues

Any assistance would be greatly appreciated.

Welcome to the forum :slight_smile:

You might be having problems because the Server IP should only be the IP address. Try removing the ‘/data’ from it.

Thank you Chris :slight_smile:

The problem is that “data” is a virtual host on the server that becomes the “website”, entering only the IP address will navigate to the WAMP dashboard:

By adding /data I can access the “website”:

Perhaps that is then my problem and my unit simply won’t work with a local WAMP site.

Thank you for taking a look.

I understand your problem now but don’t have a quick fix, partly because I’ve not used WAMP for many years!

Would it be possible to give the virtual server its own dedicated IP address, e.g. and then your station could talk to it on that address?

Hi vigilantism,

Please test local in your browser with
You should get an error message about missing passkey… And in the pwsWD/ecowitt/ folder there should be a log file updated with the error message also.

Also check if there is a .arr file with a current time stamp.

You mention “does not appear to connect” but if there is a recent .arr file, that file arrived from your weather station.

If there is no .arr file you can test with only the ip-address in the server IP address field and add the /data before the /pwsWD string in path

I currently have no access to a computer until next Monday.

If possible you could use external access in your modem/router to better test.

It would also help if you posted a screenshot of the pwsWD/ecowitt /folder contents with the times and permissions of the files


In fact, only the name or IP address of the destination may be entered under Host/IP address - without http and without any other characters.
So please enter there and then /data/pwsWD/ecowitt/ as the Path
These settings should then be correct.

To check the basic transmission capability of the console, EAR is recommended.

Good luck, Oliver

Thank you Chris, Wim and Oliver!

It is working now.

It was as simple as changing the paths as you directed:

I guess it just proves that when you have been too close to a problem for too long, even the simplest solutions elude you.

1 Like