Custom talking file names.

I now have 37Q Build 80 installed - for two days. Completly missed the fact that now there is a new weather talk file being generated.
I have
[Talk on] [File on]
[Custom speech on]
[Custom file on]

File name to use [weather_report.wav]

I now have one file being generated. (I just checked the date/time stamp)

filetotalk.wav 769kb

What I’d really like is for ‘filetotalk.wav’ to be named ‘weather_report.wav’. In fact, I’d like to be able to give that file any name I like.

Is this possible? am I missing something somewhere?

ok, PS. It seems the Weather Talk area needs work. Sorry. If I have [Talk On] and press TEST, I get a [file not found] error pops up.
With it off - no worries.
It says on the screen that it saves, when you press Test, as talkinnew.wav, and this doesn’t happen.

The only file being created is ‘filetotalk.wav’


I will do some testing and checking of this soon

not sure why you have 3 different threads on this subject?

Yea, sorry Brian.
Here’s a screen shot of my current setup.



Also the wdisplay.ini relevant part

driver=Adult Female #1 British English (L&H)
audio device=-1
file name=weather-report.wav
file name new=weather-reportnew.wav
file time=3
start hour=0
stop hour=23
voice update freq=30
file update freq=15
do link=yes
do link2=yes
upload mp3=no
do custom speech=no
do lame=yes
no 2=no <----------- ???
do custom file=yes
do warning=no
upload each minute=no
do hum=yes
do baro=yes
do rain=yes
do dir num=no
do time=yes
do hum file=yes
do baro file=yes
do rain file=yes
do dir num file=no
do time file=yes
do it=no
do it override=yes
do it file=yes
intro=the weather report from quantum radio ,.
intro file=the weather report from quantum radio .
file location=F:\My Websites\QuantumRadio\weatherdata
sample hz mp3=9000
driver new={227A0E40-A92A-11D1-B17B-0020AFED142E}
use 8 bit=no

Ok, I’m going back to an earlier version. I use the weather talking in my radio stream, and Build 80 isn’t working.

just testing here

with the custom switchs off, the file to use name is created OK

with the custom switches on, and a file setup with custom tags in it
customtalking.txt, for the talk outlout
for the custom file (for the file name set to use)

works correctly

so no problems here with build 80

I also check the custom file times
and that worked

one thing to note
make sure you are using the full install build 80, to get the separate weathertalker.exe program , included with the full install files

[color=red]I then decided to duplicate your settings …the difference was you had the talk switch off

with the talk switch off, and only the file switch on

the set file name was not updated

use a new .zip, build 81 update , ready now, to fix that #-o[/color]

Great Brian, I’ll give it a go.

I found with Build 80, that if I had both Talk and File switches on, it gave an error [File not found] - I have no idea what file it was looking for, as it didn’t say.

This is the download I used. At the top of the list.

Weather Display Downloads
Main Weather Display install file v 10.37Q build 80
for Windows 2000 / ME / XP/VISTA/W7 & NT
Version on 11 October 2011 - 00:52:09

24.51 MB Download

Anyway, I’ll do Build 81, when it’s available, and see what happens.
Thanks very much for your help,


I have fixed that error now
re download build 81 .zip again now

school holidays here, kids at home…bedlum…

Where is the zip Brian? forget I said that… doh!

ah yes. Holidays - I remember them well :slight_smile: Mine are all grown up now and my grandkids, well, I can give them back. haha

Sorry Brian. No success here still. I’m back to using Build 46.

The attached screenshot is from Build 81,

Note. all switches are on for this screen shot. It does generate a talking file, but errors out anyway as you can see.

With Build 46, I have [Talk off] and [Custom Speech off], and it generates the talking file fine.

IF I leave [Talk on], and press [Test], the [Test] button never comes back again.

For what it’s worth I. No problems at all up to this last week/updates

Oh, and I noticed this morning that the file kept saying that it was 6.30, even though the generated output gave the correct time, same problem as as the other chap is having.


This is what I’m using now. Build 46
I have attached the screen shot of B46.
I have attached screenshot two file lists. Now this is VERY strange.
Their creation times are virtually the same - I did the first one, came back - and found that one file was gone all together. Anyway - compare them for yourself. I give up…

The talking2.wav file is now the only one being generated on time, as it should be.

This B46 set up is working - so I’m going to leave it alone. A suitable file being generated, the right time being given