Current weather error

new fresh install on local server for home use… everything works only the current weather gives error.

http://217.63.198.250/index.php?theme=dark&lang=nl-nl&units=metric

Hi soulmaster,

This is the debug information from the sky block:

sky_block.php (24) version =>sky_block.php|01|2020-11-20|
sky_block.php (33) include_once =>PWS_livedata.php
sky_block.php (38) include_once =>ccn_cltraw_block.php
ccn_cltraw_block.php (24) version =>ccn_cltraw_block.php|01|2020-11-21|
ccn_cltraw_block.php (33) include_once =>PWS_livedata.php
ccn_cltraw_block.php (73) conditions from provider $textXX=Overcast and gloomy. Dry. 
ccn_cltraw_block.php (83) icon from provider data  currentweathericon=18 $iconXX=pws_icons/ovc.svg
ccn_cltraw_block.php (90) include_once  =>darksky_ccn_block.php
ccn_darksky_block.php (33) version =>ccn_darksky_block.php|01|2021-05-25|
ccn_darksky_block.php (42) include_once =>PWS_livedata.php
ccn_darksky_block.php (47) include_once  =>fct_darksky_shared.php
fct_darksky_shared.php (21) version =>fct_darksky_shared.php|01|2023-02-15|

The “current weather / sky” block uses the icon and description form your Clientraw file.
That file does not contains a “1 hour fgorecast” which is normally displayed below the sky conditions.

To get the 1 hour forecast, the script tries to find a data-file from either darksky (alternatives), aeris or metar.

Your settings have a darksky(=openweather) API key

But the load files script can not get correct data with those settings
http://217.63.198.250/PWS_load_files.php?test

PWS_load_files.php (502) Darksky_______: time spent: 0.0338 - 
PROBLEM => http_code: 500, no valid data 
http://217.63.198.250/PWS_Dark_Openweather.php?lang=nl-nl

Check if there is a typo or similar.

Succes,
Wim

The “current weather / sky” block uses the icon and description form your Clientraw file.
That file does not contains a “1 hour fgorecast” which is normally displayed below the sky conditions.

Strange enough, this clientraw file is also used @ www.weerstationmedemblik.nl and no problems.

Henk

Please re-read my previous answer.
The clientraw is not the problem. It contains the correct icon and sky-text.

The sky-block script then tries to ge a 1 hour forecast which, according to your settings, should be available from openweather.
The load-data script in website 217.63.198.250 gets invalid data.

http://217.63.198.250/PWS_load_files.php?test

That weerstationmedemblik site correctly gets correct openweather data

https://www.weerstationmedemblik.nl/PWS_load_files.php?test

Carefully compare your easyweather settings for darksky (=openweather) between those two sites.
Only you can do that as others have no access to your easyweather settings.


If the problem persists and your 217.63.198.250 is accessible by FTP:
sent me an email with FTP userrID and password and your 2023/4 support token

Succes,
Wim

Differences between your websites:
Your main website weerstationmedemblik is using an old beta version of PWS_Dark_Openweather.php|01|2023-02-15 which has a few small beta-test differences
→ it uses the forecast data longer: for 600 * 100 seconds = 16 hours
→ it uses a “developer testing” API-key in line 139

Your website 217.63.198.250 is the recent version of the script
That one loads the API-key from your easyweather settings.
You will need to obtian your own API-key from easyweather as the developer keys are obsolete in a few months.

Check your settings if your OpenWeather key is correctly entered

  1. TAB → Api & keys
  2. Question → Darksky and alternatives after March 31, 2023
  3. Selector → OpenWeatyherMap
  4. Field “API Key for forecast and current conditions.” → copy/paste your API-key