Cronjob fails, min/max values incorrect

I have tried the fix that @novawx did but I am still having problems with the min-max temperatures. I used PWS_hist_update.php and also PWS_hist_recreate.php. I am running PWS_cron_stationcron every five minutes from but the temperatures either don’t update correctly, or the time-of-day shown is also incorrect (often from some time the previous day which hasn’t occurred yet. I get better results when I manually run PWS_cron_stationcron.php from the “command line” in my browser but this is not obviously useful going forward. The result from a test run of the cron job at Cron-job,org is:
Server: nginx
Date: Tue, 24 Oct 2023 15:48:17 GMT
Content-Type: text/html
Content-Length: 884
Connection: keep-alive
Expires: Thu, 01 Jan 1970 00:00:01 GMT
Cache-Control: no-cache

This site requires Javascript to work, please enable Javascript in your browser or use a browser with Javascript support

where I have replaced my password with asterixes. I get the same result without adding the password to the I don’t understand the Javascript thing being applicable. When I manually run the cron from the command line I get a different result:
success files loaded + history recalculated + history saved + need upload to others + 0 uploads + no roll-over needed 2023-10-24T13:07:48-03:00

The site I am having trouble with is:
and a similar problem at:

The website associated with me elsewhere here is still working with a previous version. I didn’t want to update my public website until I had any problems worked out with the new version.

In my just-previous post a bunch of html doesn’t show either side of the line about Javascript. I can try to upload that here if I could see a way of doing so that can be read.

It seems your webhosting-provider needs javascript in your browser to allow scripts to run.
Some “free or inpensive” providers do that to get some “income” from tracking you and your visitors to show adds or do other nasty things.

As you already tested the link is correct

I did test with my cron-provider and it showed the same results as yours.
There was a lot of garbage returned from your website.

<html><body>function toNumbers(d){var e=;d.replace(/(…)/g,function(d){e.push(parseInt(d,16))});return e}function toHex(){for(var d=,d=1==arguments.length&&arguments[0].constructor==Array?arguments[0]:arguments,e=“”,f=0;f<d length;f++)e+=(16>d[f]?“0”:“”)+d[f].toString(16);return e.toLowerCase()}var a=toNumbers(“f655ba9d09a112d4968c63579db590b4”),b=toNumbers("98344c2eee86c3994

Does no bother which script I used always your provider wants to install some tracking javascript

IMHO yu can do two things.

  1. use another provider
  2. Check if your provider allows running a cron job


Thank you for a very quick response. The three different free hosting providers I have used all want money to run cron jobs. I guess I will have to work on my paid-for-provider site. Good to know. I have already backed up my paid-for site.

@ ALL Do not forget:
Always run easy weather-setup after moving a website from one location to another.
The settings contain the file path and they are different for each provider.
Also when moving or renaming your pwsWD folder, you have to run easy weather setup.
You open easy weather-setup and only have to click on the green save button.


I successfully (I think) did the update. I had one customized .php file I needed to re-customize the new version, but happily for me that worked fine with copying the applicable lines from my old version.