COM port problem - WS2050 and DELL pc - HEEEEELP!

Hi all - I am new here and have a BIG problem.

I bought a WS2050 a couple of years ago, used it with my old steam operated pc, WIN98, Pc Weatherstation software that came with it and a serial port with no trouble at all.

Hmm. Bought myself a nice new DELL Dimension pc and thought I’d also treat myself to Weather Display 32. Problem #1 - No serial port. OK, easily fixed, bought a USB to RS232 adapter and intalled driver. According to the device manager the pc is seeing the adapter ok and assigns a COM port to it, but the WeatherDisplay doesn’t read it when I configure it for that COM port. Tried it in all the available USB ports, same thing.

So - I had a serial PCI card fitted with 2 x nice serial ports. Same thing - pc recognises the ports, assigns a COM port number to them, but no data is getting through.

When I plumb it back into the old pc, which is still cluttering my desk, it works fine. Loaded Pc Weatherstation software in new pc and it doesn’t read it either.

I have tried asking for help where I bought the WS2050, and they have been extremely helpful but run out of ideas (plus, of course, the fault isn’t with anything they have sold me, so their goodwill is running a little thin now.)

Any ideas, before I throw it all out of the window?

Do you have any other RS232 devices available that you can use to see if anything else can be seen on the end of the USB->RS232 adapter? Maybe an old modem…see if you can get a response to some AT commands.

Also check that you have the latest drivers for the adapter…and even whether the adapter needs drivers (Windows XP can handle some adpaters with the built-in drivers).

Didn’t I read somewhere that some of the La Crosse stations can’t use Serial to USB adaptor?


Well I’m using a serial to USB converter with WS2315 and it’s doing ok, the problem is with the PC I have 6 USB ports and it will only work in one particular USB port, strange but that’s how it works. I was just about to give up with the converter and accidently found that out.

the 2500 needs a fast wake up response, which USB to serial is not suited to

i sent a possible solution on this already, here it again

try reducing the wake up timer for the ws2500 in the view, ws2010/ws2500 data setup and view

Hi Brian,
It doesn

Looks like I need to fiddle about, perhaps. Changing the wake up speed was the last advice I got from the suppliers, which I did with no effect. But I only tried it on one of the COM ports available via the USB adaptor. If I try it with a higher speed (is 10 ok?) on all the ports (maybe the serial port first?) then, bearing in mind what you say, Peter, maybe one of them will work.

I’ll report back sometime tomorrow when I get a chance to play, but meanwhile thank you for your advice!

Also check whether any of your USB ports are set for auto-power down. If they go into power saving mode they might not be waking up properly. Finally, if you have a USB hub try the adapter on that. None of these things may help in this case, but other people have tried them with some success when having USB port problems.

You might want to focus on the PCI card ports, that would take USB out of the mix.

You might want to think about setting up a hyperterm to see if there is any data going through the COM port. It may look like gibberish but that would prove that the COM port is working or otherwise leaving you free to look for other solutions.

OK, had a fiddle about today.

Before I report about todays failures, a little more background.

Firstly the disclaimer - I am a complete technophobe and went beyond the limit of my knowledge and comprehension some while ago. I found some of the advice above beyond my limit I’m afraid.

I had Pc Weatherstation software only installed on my old pc, so was unable to make any comparisons with WD software.

When the serial PCI card was installed the guy checked it was working ok with a serial mouse and something else.

Ok - what I did today.

Firstly I made sure the wake up timer value was reduced - I put it down to 10.

Then I tried connecting the WS2500 to all the available ports I have - all the USB ones (including those with other equipment on) via the USB/serial adapter and both the serial ports directly. Each time I looked on device manager to see which port I was on, then checked the box in WD software to correspond. In all cases the box ‘Data Received’ flashed green, but only 1 value was registered. When I removed the lead from the port the green in the box disappeared.

Finally, I installed the WeatherDisplay software into the old pc to see if, by some chance, it was a duff copy - and it seems to work.

Anyone any further ideas? And, if so, can they be explained in words of one syllable or less!

Are you using a different serial cable?

Is it doing the same with the serial ports (PCI) in the new PC, or just the converter?

Peter, so far as i can see it is behaving the same way whichever port I try to connect to. The Data Received box flashes green, I get 1 reading and that’s it. I tired it in the USB ports that my mouse, keyboard, printer, scanner are plugged into, plus the 2 other spares, plus the two new serial ports.

Nikoshepherd - when you ask if I am using a differnt serial cable - different to what? Sorry if that is an elementary query, but I’m afriad I don’t understand!

Is the cable you are plugging into the back of the new PC physically the same one you were using before?

So you said before that it works with the old PC in the serial port with WD, check the setting in the new PC and at the moment stick with the serial port in the new PC. Which port do you use like com1 or com2? did you touch any settings from the com ports in the new PC, compare the settings in both.

Nikoshepherd - sorry, yes, physically the actual same cable.

Peter - when the new serial PCI card was installed the two new ports we assigned as COM 8 and COM 9. At one point I changed them to COM 1 and COM 2 in the ‘advanced’ tab, these two numbers being shown as free, in order to try and get Pc Weatherstation working (it only recognises up to 4 COM ports) but that didn’t seem to make a lot of difference so I have changed it back again.

The only difference I can see, when looking at COM port properties, is under the tab ‘resources’ for the old pc the Input output range is 03F8 - 03FF and the Interrupt request 04. For the new pc these values read DC88-DC8F and 17 respectively. I have absolutely no idea what this means - is it likely to have any importance regarding this?

Well change them back (the PCI card) to com1 and com2 so you can get the same interrupts as the old one. What shows now is virtual ports and might be a problem. I do not have the same weather station as yours but it looks like a PC problem and not a station problem. Once you do it put com1 in the WD setup and leave it for a while.

Hmmm, I’ve done as you suggest and there is no change. It is trying to read it - the data box is flashing green, but nothing is coming through. Maybe my next port of call (Lord, was that a pun? Very nearly…) is to Dell and ask them what the &*%^$%

Spoke to Dell technical support. They say that the machine, as sent out to me, works perfectly, which it does - plus the device manager recognises the new ports and adapters. Not their problem.

The adapters and ports all work perfectly well with a serial mouse, so the manufacturers tell me it is not their problem.

The WS2500 works perfectly well in my old pc, so my suppliers tell me it’s not their problem.

WS10.32 works on the old pc, so that isn’t the problem.

Everything works individually, yet put it all together and it doesn’t work. I find myself with several hundred pounds worth of weather station equipment that I can’t use.

And it seems that is my problem.

Anyone any last ditch ideas?