Clientrawdaily.txt not being generated

A few updates ago, all of a sudden my clientrawdaily.txt files are not being updated. The other three clientraw files (clientraw.txt, clientrawextra.txt, and clientrawhour.txt) are updating OK. When first starting WD, a correct clientrawdaily.txt file is generated, but it does not generate thereafter until stopping and restarting WD. In other words, if I leave WD running for a week, the clientrawdaily file will be a week old and the other clientraw files will be up to date. If I then stop and restart WD, the correct (updated) clientrawdaily file will be written once and then not be updated until the next time I stop and restart WD.

Searching through the forum, I see that this has been a problem for others but I couldn’t find any resolution. Like I said, it HAD been working just fine until a few updates ago (I don’t know exactly which). As far I as know, I have changed no settings that might cause this. Besides, I don’t think there is a setting that could stop the generation of just the clientrawdaily file, is there?

Thanks in advance for any advise you can give.

the file should be updated 4 times a day

is WD running at those times?

any error under view, program event log?

I have WD running 24/7/365. There are no errors in the program event log (it’s a blank window).

try deleting that file, where the other clientraw files are

to see if it get recreated at one of the times listed above

what speed pc, how much memory, windows version, etc?
does the minute 11 show in the logfile?

I will try deleting clientrawdaily.txt file and see if it is generated at specified time and then report back.

I have not changed hardware or OS in well over a year, long before this started. Intel Quad Core i7 processor, Windows 7 Pro 64-bit, 8 GB memory.

Don’t know what you mean by minute 11…

minute 11:
look in the logfile
is a minute 11 redorded OK?

I have changed one thing, that might help
try a new .zip update, ready now

Yes, it looks like there is a line written at minute 11 for each hour in the 12011lg.txt logfile.

Will try the new .zip update and let you know. Thanks!

Maybe check the 102011lg.txt file :wink:

ops, typo, thats what I was meaning

Same in 102011lg.txt file…line written for minute 11 at each hour.

Something else I just noticed also. I have WD set up to also write all four clientraw files to another location via FTP. (So I have them written locally and to an external FTP site.) I just noticed that only the clientraw.txt, clientrawextra.txt, and clientrawhour.txt files are being sent via FTP. The clientrawdaily.txt file is not being sent. I discovered this because I deleted the clientrawdaily.txt file on the remote location, and even though there is a clientrawdaily.txt file locally on the computer running WD, it never gets copied over to the FTP site. The other three clientraw files are getting copied over normally every 30 seconds. [Or maybe I don’t understand how this is supposed to work. WD probably sends to the FTP site and writes locally simultaneously (?) and doesn’t actually copy from local to FTP?]

I’ve attached a screenshot of how I have it set up in WD.

Still not working. It’s been over 24 hours and clientrawdaily.txt has not updated. I have updated to build 82 of WD.

its strange you have this problem
as there are no other reports of this problem
and the only change to the clientrawdaily.txt was adding some rain average data to the end

.zip and email me your settings files and I will test here

They may not be real recent, but a little searching found that others have had this problem also…
…and I couldn’t find any resolutions.

I have emailed you the settings files. Thanks again for looking at this.

works OK here with your settings
(I set the clock to 09:10 and the file was updated OK)
but I notice you have WD installed to c:\program files
not a good idea , could be a permissions problem
I would instead install to the default location of c:\wdisplay

ps, none of those links you have posted relate to the particular problem you are having

I’ve had it installed in that directory (C:\Program Files (x86)\Weather Display) for 5+ years and it’s worked flawlessly up until a few builds ago. Didn’t change a thing with the OS or anything else I know of on the computer. And besides, if it were a file permissions problem, why would the other three clientraw files be updated OK and only the clientrawdaily file have the problem? Isn’t it written to disk the same way?