Bad Data Stream WS2310?

bad temp
rain= 0.0 mm
Bad wind
Bad hum
Bad wind
Bad hum
rain= 0.0 mm
rain= 0.0 mm
rain= 0.0 mm
Bad wind
rain= 0.0 mm
bad temp
rain= 0.0 mm
rain= 0.0 mm
rain= 0.0 mm
bad rain
rain= 0.0 mm
rain= 0.0 mm
Bad icon
rain= 0.0 mm
This is a copy of the sensor data stream…my readings appear to be normal on the display but , I have been recieving all of these “bad” readings any ideas? I have rebooted and also downloaded the 9.44 version…no change.
Jon Paul

Hi John
Its just when there is bad communication…
it happens every now and then…with that station type…
and wd rejects the data
nothing to worry about :slight_smile:

I have exactly the same with my WS2300.WD constantly sends out an request for data on the RS232 port. Sometimes it creates a collision with the data sent out by the WS2300. Then you will get a bad reading…

As Brian said: nothing to worry about…

Thanks,
I was more worried about my station than the software…I’ll quit worrying then :slight_smile:
Jon Paul

it was only there for debugging
i will take it out
John, is the barometer working oK for you on the latest version?
and do you have any crashes of wd with the latest vers?

I haven’t downloaded 9.45 yet, but so far everything is working fine. I haven’t noticed the barometer giving any trouble. I still have all the “bad” readings on the data stream but the readings are still coming thru. I’ll keep my fingers crossed. :slight_smile:
Jon

Hi John
back up your current verison,and please try 9.45b, and let me know

Will do Brian,
I’ll download it and run it tonight…let you know tomorrow!
Jon

Brian,
I am running 9.45c like you asked…there may be a problem I had a computer crash shortly after an ftp upload, I checked the prog error log and it said
ERROR: Invalid floating point operation at…then listed a time at about 1 to 2 minute intervals

Jon

hi
its a divide by zero error

i will try and find it…

oops

i added average windspeed for the real time graph, and that is where that new bug came from
(i also now have max gust since last update to the real time graph)
i hope to soon fix saving/restart probs with the real time graph

uploading a new vers now