Autoscale "None" option glitch

Hi Brian,
Thanks for implementing the “None” option on autoscale graphs. One glitch is that when I select this option, the scale on that axis continues to be displayed with whatever units were last graphed. Is it possible to remove the scale, or at least make it match the actual single item being graphed.