After installing the latest updates allignment forecast module on mobile not correct

After installing the latest updates today, the alignment of the multi-day forecast on the mobile is no longer correct (no problem on the website in Windows itself), on the right side there is an empty box, which is not filled in properly.
Is there perhaps an error somewhere in the “PWS_index2.php” file?
See attachment.

greetings Arie
www.meteo24-culemborg.nl/pwsWD/

This is a un-detected side-effect of the “more space on a phone in tall mode” feature.
As you already pointed out, dashboards with 2 or more blocks in a row do not show that.

There was a discussion to add that feature,
I did not get any comments, so I assumed it was ready for release.

I will check that tomorrow with the requestor of this feature.

Wim

Well, I could not find the requester and the topic.
Maybe the OP deleted the topic, the question was hinnen inside another discussion or my eyes are failing also.

This feature will be removed in the next update.
Changing and testing all forecast blocks is a lot more work.

Wim

Could it be that the solution to this problem has been lost in the latest updates from 31-10? It’s not very important, just a small cosmetic problem.
Wim, I hope you still find time to solve this.

Thanks!

Greetings,
Arie

That should have been OK already.
The latest update does not include PWS_index2.php which had the CSS update for the small blocks.
Will compare your PWS_index2.php with the full download / last updated
one.

Wim

Schermafbeelding 2023-10-31 om 23.27.00

I compared my PWS_index2.php with that from the full download and actually saw no difference, except for a stripall function, but I don’t think that’s the reason, see both php files.
I have also added a screenshot from my mobile, which clearly shows that the alignment is not correct.
Can you take a look again, thanks in advance.

gr. Arie

PWS_index2.zip (19.7 KB)

The problem is not with index2 but with fct_aeris_block.php|01|2020-11-02|
Change line 54 which reads now:
echo '<div style="width: 314px; overflow: hidden;">
to
echo '<div style="overflow: hidden;">
That should solve it.

Succes,
Wim

That solved the problem,
in my case in the corresponding line in fct_yrno_block.php.

Thank you very much

That was the cause, solved.
Thanks.