Adjax Template won't update for me on first load of page but it does for others.

I’m pretty sure this started after my Erice server was upgraded.
When first going to my site, the ajax doesn’t update even after waiting a minute or more. But if go to another page on my site, it starts updating immediately. I can go back to the index page and it’s now updating.

If I leave the site, and go back, it once again doesn’t update until I go to another page on my site.
I’ve opened and watched realtimeclientrawftp and it chugs right along uploading without errors, so I don’t think that is the issue.

Appreciate any suggestions!

Try clearing cache/cookies/temp int files etc… and then try browsing your site again.

Ok, tried that and no change.
Occurring here on all three computers in the house.
the data is updating, and changing, every 3 seconds or so, OK Here for me

Updating on my browser also…about every 3 seconds…

It’s OK here, too, updating about every three to five seconds. Running Firefox 3.6.10.


Hmmm, ok thanks guys. I appreciate you taking a look.
It’s still doing it to me this morning.
I’ll try a modem and router reboot.

Are you using IE8+ for your browsers at home?

If so, your ajaxWDwx.js (Version 2.16 - 20-May-2008) doesn’t have the IE8+ fixes in it.
Current version at which has

// — Version 2.17 - 25-Jun-2008 – added gizmo-specific ajax variables
// — Version 2.18 - 20-Mar-2009 – added fix for ‘green-flash’ issue with Internet Explorer 8
// — Version 2.19 - 03-Jul-2009 – additional gizmo-specific ajax added, and useHpa variable for pressure
// — Version 2.20 - 16-Jul-2010 – reduced JS warning msgs by adding var and new x-browser request method finder
fixes in it.

You may also need to add the fixes into ajaxgizmo.js (or update ajax-gizmo.php and ajaxgizmo.js from the current distribution)

Best regards,

Thank you Ken, I wasn’t aware I was so far behind on updates!! 8O

Ok, I’ve updated the files, ajaxWDwx.js, ajax-gizmo.php, ajaxgizmo.js.
And nothing’s changed, still the same issue.

Yes I’m using IE 8 on all machines.

What happens if you look at other template sites using that same browser?

Tried 10 other template sites, and all 10 load and update fine, but not mine!

Just checked your site with IE8 in both native and compatibility mode and the AJAX works fine for me :slight_smile:

I suspect there’s an issue with your home browser. :dontknow:
Do you have a software firewall or browser plugin that may be denying access to your site?

Best regards,

I’ll dig around, but not really sure what I’d be looking for.

Thanks guys.

Your site looks good here too on IE 8 on Win 7.

Try doing a shift-reload of the page (hold down the shift key, press the reload button) … it may be that the browser has cached the old javascript and is not fetching the new version.

Ok, finally had time to dig around. Nothing jumped out at me.
Not many addon’s in IE.

I tried the shift reload and no joy. :confused2:

I have Norton Internet Security 2010 on all 3 affected machines. As far as I know, it’s never caused any issue’s. If it has downloaded an update that now is blocking this, what would I look for to try to find it and turn it off.
Just get’s my goat that other sites update ok for me, just not mine. :confused1:

Have you tried disabling Norton?

Niko, yes I’ve tried disabling Norton. Doesn’t cure it.

For fun I’ve dug through the firewall advance settings, and found nothing that appears that would cause the issue.


Try setting your website to ‘trusted’ in the IE properties dialog … it might help :slight_smile: