AAG barometer - flatline at 1013 mb [RESOLVED]

I know this topic has been discussed before but I’ve not found an answer
Note - dates are UK format dd/mm/yy
Running Windows XP, 1-wire system, latest WD 10.37Qb82, 1-wire reader 4.9 01/10/11, aagbaro 24/06/11
I’m using a Hobby Boards barometer. via a 6 way port but the baro is on the “passthrough” connector.
I’ve ticked AAG baro. I’m assuming this is correct.
1 wire reader finds the baro and the hub routine gives values for VAD and VDD (and convert flags)
aagbaro used to appear briefly on the task bar, but now doesn’t and the WD main screen has the pressure constant at 1013.0 mb
I’ve attached a screenshot of 1-wire reader
Wind direction is shown as — on the Current Raw Readings, but displays correctly in the main WD screen.
Is there something I’ve missed in the setup or is this a bug?
It used to work up to about 1 month ago (I’m not sure which version of WD that was as my PC broke)
I’m also getting spikes and flatlines on the humidity, but that could be the Hobby Boards module. I need to buy a new one from Eric to be sure.

the AAG baro is read via a separate program
so do not enter a ROM ID for that

there is a debug version
i.e stays open so you can see what it shows

re the humidity, some one reported changing or adding a capacitor helped with spikes (i.e a hardware problem)

I’ve removed the ROM ID from the list, left ‘Use AAG Baro’ ticked (and clicked save/reset) then restarted WD. It now tells me it has found that rom but it hasn’t allocated it to the barometer. aagbaro still reports ‘no roms in the list’. The VAD and VDD values are no longer listed in the left hand pane of Reader
Thanks for the suggestions about the humidity. I’ll search the forum posts before spending money on a replacement module.

the test aagbaro reader I posted works OK here, tested that

do you have the correct connection type set in the 1 wire reader?
also make sure to make changes/save settings to the 1 wire reader when WD is not running
(i.e start that program up manually after exiting WD)

I’m using the USB port. AAG Baroreader reports comport number = 1, USB type port in use, No roms in the list.
All the other instruments (wind speed & direction, temp, humidity, rainfall) work ok.
I’ve checked the barometer with 1 wire Viewer (see below and attachment) and I’m getting sensible readings from the A to D

Yes, I make changes after shutting down WD (which also shuts down 1 wire Reader). Make the changes, save/reset then close 1 wire Reader and start up WD which starts 1 wire Reader.

Is there any logfile I could post which might point to the problem I’m having? It worked fine on my previous installation before that PC died.
I can read what was on my previous hard drive (I put it in a SATA to USB housing) so it’s obviously some other hardware that failed.
Are there any relevant files where I could compare my current installation with my ‘old’ installation?

If I try to open 1 wire Viewer with 1 wire Reader open, it won’t let me. Although the other instruments work ok, is there a possibility of some conflict between 1 Wire Reader and aagbaro.exe, even though 1 wire Reader is not running?

the no roms in the list means the aagbaro.exe program can not find the sensor

try having it as the only thing on the microlan or similar , as a test
my test here is having it plugged directly into the 1 wire USB adaptor

Easier said than done :slight_smile:

Even I wire viewer won’t find the baro on a short (1m) cable. I had to make up a 10m extension. Fortunately I have lots of cable and connectors and the proper crimping tool.

OK. Done that. 1 wire viewer finds it and reads the A to D voltages.
No change with respect to 1 wire reader/WD/aagbaro (or Baronoclose).
1 wire reader finds the ROM ID, WD still reads 1013mb, aagbaro reports no roms in list.

I then unticked ‘Hub attached’. save/reset/close. restarting I get 2nd pane reporting ‘searching for switch’. After about 1 minute the first pane reported ‘running AAG baro’. Close reader. Open WD. After a short delay baro reading appears, still 1013 mb.

Put everything back as it was, but included the additional 10m of cable. Still no change from 1013mb :frowning:

What I don’t understand is this - if I DO put the baro ID in the ROMs list, the baro VAD and VDD voltages appear in the left pane of 1 wire reader (and they match the values shown in 1 wire viewer) but WD seems to be ignoring the readings.

What I don't understand is this - if I DO put the baro ID in the ROMs list, the baro VAD and VDD voltages appear in the left pane of 1 wire reader (and they match the values shown in 1 wire viewer) but WD seems to be ignoring the readings.

because those ROM Ids are not the ones used for the actual barometer reading
i.e thats a bit of a wild goose chase

the actual chip used is one similar to the leaf wetness/soil moisture or the AAG WS603 station
i.e the battery monitor chip ,DS2760

its that chip that the maximum 1 wire reader would need to be able to see

note that 1013mb is just a default value

Aha! Now we’re making progress :smiley:
The actual chip on my Hobby Boards barometer is not the DS2760 but the DS2438. I assumed the AAG baro was the same.

The temperature/humidity board also uses the DS2438. Regarding the spikes I’m getting on the humidity, I read this PDF
that states “Honeywell HIH3610 and HIH4000 sensors will fail over time if exposed to condensing humidity environments”
That could be my problem. Hobby Boards uses the 3610 sensor.

Back to the baro problem…
Yes, I understand about the default value.
The strange part is that it worked fine up until my PC broke.
Unfortunately I can’t easily tell you what versions of WD/1 wire reader/aagbaro I was using on that PC but I do know that I hadn’t done any updates for quite a while - maybe not since early 2011.

you could try clicking on reset calibration
does the aag test software work with the barometer?

Reset calibration apears to have no effect.
I’ve searched the web for aag test software but can’t find anything. Do you have a URL?
Just checking my old hard drive. I can’t find any aagbaro.exe program and it seems that last time I updated WD was 22/12/2009 !!!

you get the aag test program from the aag website…

Sorry Brian. I’ve just spent the best part of an hour looking for the software on AAG’s website and searching Google for anywhere else that may have had it, or a link to it, but I can’t find it.

Oh, I was thinking of the weather station software
I will email you a link

After a few emails with Brian, he identified the problem.

I had not entered any values in the 4 boxes at the bottom of 1 wire reader for low pressure and high pressure hpa/volts.

I’m running a new installation since my previous PC died, so had to enter everything, ROM IDs, offsets etc. from scratch.
I don’t remember entering the hpa/volts values when I first started using WD several years ago, but presume I must have done.

So, my system is running again with all the sensors being plotted :smiley:

the other key was it was not an AAG barometer in use…

Yes, I made the mistake of thinking that the Hobby Boards barometer was the same as the AAG

Sorry to open an old thread but I am having the same problems. where do you find the values to enter in to the boxes at bottom left? I too could not find the AAG test software but I can read the barometer with other software so i know its working and it also says AAG on the box.

Best wishes


you do not need those values if it is in fact a AAG baro
just tick you have an aag barometer

Thanks very much. Definitely an AAG , stamped on the case.

Best wishes